Project Explorer

Explorer View Icons

Explanation of icons next to the file names:

Icon Explanation

Minus grey icon (gray) File not belonging to the project.

Plus grey icon (gray) File not belonging to the project, but directly or indirectly included in a file belonging to the project.

Check green icon (green) C source file (Options > Project / File Types / C Source file).

Check green small icon (green) Not a C source file.

Minus green icon (green) Header file (Options > Project / File Types / Header file) not included directly or indirectly.

Check green with red hyphen icon (green with red hyphen) Read-only C source file.

Check green with red hyphen small icon (green with red hyphen) Not a C source file, read-only.

Minus green small icon (green with red hyphen) Read-only header file not included directly or indirectly.

Clicking the icon next to the file name changes the file status within the project.

Folder View Icons

Explanation of icons next to the file names:

Icon Explanation

Minus grey icon (gray) File not belonging to the project.

Plus grey icon (gray) File not belonging to the project, but directly or indirectly included in a file belonging to the project.

Check green icon (green) C source file.

Check yellow icon (yellow) C source file. The original file does not exist, but one with an alternative extension or within the referential path was found.

Check red icon (red) C source file. Neither the original file nor an alternative one exist.

Check green small icon (green) Not a C source file.

Check yellow small icon (yellow) Not a C source file. The original file does not exist, but one with an alternative extension or within the referential path was found.

Check red small icon (red) Not a C source file. Neither the original file nor an alternative one exist.

Minus green icon (green) Header file not included directly or indirectly by the file belonging to the project.

Minus yellow icon (yellow) Header file not included directly or indirectly by the file belonging to the project. The original file does not exist, but one with an alternative extension or within the referential path was found.

Minus red icon (red) Header file not included directly or indirectly by the file belonging to the project. File not found.

Check green with red hyphen icon (green with red hyphen) Read-only source file.

Check yellow with red hyphen icon (yellow with red hyphen) Read-only source file. The original does not exist, but a file with an alternative extension or within the referential path was found.

Check green with red hyphen small icon (green with red hyphen) Read-only file (not a C Source nor a Header file).

Check yellow with red hyphen small icon(yellow with red hyphen) Read-only file: the original file name does not exist, but one with an alternative extension or within the referential path was found.

Minus green small icon (green with red hyphen) Read-only header file not included directly or indirectly.

Minus yellow small icon (yellow with red hyphen) Read-only header file not included directly. The original file name does not exist, but one with an alternative extension or within the referential path was found.

Logical View Icons

Explanation of icons next to the files:

Icon Explanation

File icon File not belonging to the project, but directly or indirectly included by a file belonging to the project.

File grey icon File belonging to the project.

File grey icon red hyphen (red hyphen) Read-only file belonging to the project.

File grey icon yellow hyphen (yellow hyphen) The original file name does not exist, but one with an alternative extension (Referential Extensions) or within the referential path was found.

File grey icon blue key (blue key) The file belongs to the VCS project and has been locked by the user whose name has been displayed in the Options > Version Control System / Project Dependent / Username box.

File grey icon red key (red key) The file belongs to the VCS project and has been locked by one or more users whose name is different from the name displayed in the Options > Version Control System / Project Dependent / Username dialog box.

File grey icon red and blue key (red and blue key) The file belongs to the VCS project and has been locked by both the user whose name has been displayed in the Options > Version Control System / Project Dependent / Username dialog box and by other users.

Shortcut Menu

Right-clicking a symbol within a Explorer view 

Activates the following context sensitive shortcut menus:

Browse pane

Project Window / Explorer view Browse pane Right-click Shortcut Menu

Details pane

Project Window Explorer view Details pane Right-click Shortcut Menu

Add to Project

The Add to Project command add selected files to the project.

Remove from Project

Use this command to remove selected files from the project. If a folder is selected all project files under it will be removed from the project. You are prompted about removing of each file.

Set as Project Root

Use this command to set Project Root directory to selected folder.

Properties (DAC)

Same as Project > Properties (DAC) program menu command.

Properties (Windows)

Displays Windows properties for selected folder or file.

Open Folder in Windows Explorer

Launches Windows Explorer. If the selected folder is reachable Windows Explorer is opened with focus on it.

Delete

Deletes selected folder or file(s).

Metrics

Opens metrics report for selected file.

Open

If the selected file is among files defined as Editable files (i.e. if the extension of the file is listed within C Source Files, ASM Source Files, Headers or Text types in Project Options > File Types dialog. A new Editor will appear and display the contents of the file. If the file's extension is not among Editable, an application associated with this file type will be launched (related to Windows file association configuration).

Print

Prints selected files.

Add to Project...

The Add to Project command adds selected files/folders to the project.

Remove from Project

Remove from Project command removes an selected file/folder from the Project Explorer. The file/folder will not be physically erased from the disk; it will only no longer be considered a part of the DAC project.

Right-clicking a symbol within Folder view 

Activates the following context sensitive shortcut menus:

Browse pane

Project Window / Folder view Browse pane Right-click Shortcut Menu

Details pane

Project Window / Folder view Details pane Right-click Shortcut Menu

Check In

Stores (checks in) selected files contents to the project VCS archive.

The command is on the shortcut menu of Folder or Logical View if one or more files are selected, a directory or group and if VCS has been set for the project. The command is enabled if at least one of the selected files has been added to the VCS archive as well as for group or directory selection. You can find out more on setting VCS support and on the meaning of this command in corresponding DAC documentation.

Check Out

Checks out selected files from project archive to working directory.

The command is on the shortcut menu of Folder or Logical View if one or more files have been selected, a directory or group and if VCS has been set for the project. The command is enabled if at least one of the selected files has been added to the VCS archive as well as for group or directory selection. You can find out more on setting VCS support and on the meaning of this command in corresponding DAC documentation.

Right-clicking a symbol within a Logical view"

Activates the following context sensitive shortcut menus:

Browse pane

Group shortcut menu

Project Explorer / Logical view Browse pane Right-click Group Shortcut Menu

Browse pane

File shortcut menu

Project Explorer / Logical view Browse pane Right-click File Shortcut Menu

Details pane

Symbol shortcut menu

Project Explorer / Logical view Details pane Right-click Symbol Shortcut Menu

Add Group

Adds new group to selected group. The new group appears with a temporary name. Type a name for the new group, and then press ENTER.

Rename

Allows you to rename logical groups. Renaming may be also done in the same way as renaming of directory folders in Windows Explorer (delayed mouse double click).

Cut Group

Moves a group to the Clipboard.

Copy Group

Copies a group to the Clipboard.

Delete Group

Deletes a group.

Paste group

Pastes a group, previously copied or moved to the Clipboard, to selected group.

Cut File Names

Moves selected file names to the Clipboard. This file names may be assigned later to a logical group by Paste File Names command.

Copy File Names

Copies selected file names to the Clipboard. This file names may be assigned later to a logical group by Paste File Names command.

Delete File Names

Removes selected file name from parent logical group.

Paste File Names

Pastes file names, previously copied or moved to the Clipboard, to selected group.

Definition

Opens the file symbol (function, variable, constant, type or macro) is defined in and positions the caret at the place of the symbol definition.

Declarations

Opens the Browser showing symbol declarations. The list of declarations also includes the symbol definition.

Uses

Opens the Browser showing all uses of the symbol.

Assignments

Opens the Browser showing all assignments to the symbol, or uses of its address.

Calls To

Opens the Browser showing all calls to the function.

Calls Within

Opens the Browser showing all calls from the function.

Uses Within

Opens the Browser showing the list of symbols which are not functions, but are used within the function which is selected.

Graph

A Graph is activated for the function which is selected.


Copyright 1993-2017, RistanCASE GmbH