"Project" Menu

Project menu commands

New Project...

The New Project command activates the dialog box used to enter the name of a new Project file. The default extension is ".DCP". The configuration and the session data of a previously active project are saved when the project is closed, if so defined by parameters which can be set using the Options > Project / Miscellaneous dialog tab.

Import Project...

Imports project from supported IDE's

Project Importer dialog box

Importer

Here, you select the application whose project you wish to import. A small green circle before the name of the Editor you are importing from marks that the importer version is compatible with your version of DAC. If the circle is red, your importer version has probably expired. Conversion with an importer so marked will not be possible, as DAC will inform you when you click the OK button.

Setup

In case the importer cannot find the configuration file of the editor whose project you are converting, you will be notified of an error during conversion. Clicking this button opens a dialog box for entering the full path and name of the required file. The appearance of this dialog box depends on the selected importer

From Project

The path and name of the Project file that is being converted.

Browse

Clicking this button opens the standard Windows "File Open" dialog box in which only files with the chosen Editor extensions are listed. In this dialog box, you can choose a Project file.

OK

Clicking the OK button will open the standard Windows "File Open" dialog box in which you specify the name and path of the destination DAC project.

Cancel

Closes the dialog box without converting — the DAC project active prior to starting the "Project > Import Project" menu command, remains active.

Open Project...

The Open Project command activates the dialog box used for opening an existing project file. The default extension is ".DCP". The configuration and session data of a previously active project are saved when the project is closed, if so defined by parameters which can be set using the Options > Project / Miscellaneous dialog tab.

Close Project

The Close Project command closes all windows in the current project. The configuration and session data of an active project are saved when the project is closed, if so defined by parameters which can be set using the Options > Project / Miscellaneous dialog tab.

Recent Projects List

It is displayed between the commands "Close Project" and "Add File to Project" and contains a list of most recently used projects. Click on desired project to open it.

Add File to Project...

The Add File to Project command adds selected files to the project.

Remove File from Project

Remove File from Project command removes an active file from the Project Explorer. The file will not be physically erased from the disk; it will only no longer be considered a part of the DAC project.

Properties (DAC)...

Activates the Properties dialog box, used for editing various options for the items (files, folder, or logical group) currently selected in the Project Explorer. 

Properties dialog box on Folder or Source file

Dialog on Folder or Source file

Properties dialog box on Header file

Dialog on Header file

Properties dialog box selected files

Dialog selected files

Skip Static Code Analysis and Software Metrics 

If activated this option prevents analysis of given source file. This ability is particularly useful with a source file (not header) that is included in other source file. Without this option, included source file would be analyzed twice, so it would lead to declaration and definition conflicts.

Skip MISRA-C Compliance check 

If activated this option prevents MISRA-C checking of given source file. Note that if you check "Skip Static Code Analysis and Software Metrics" then "Skip MISRA-C checking' will be checked automatically. 

Skip Naming Convention check 

Naming Convention check in source files from licensed third party libraries usually does not have sense, so selecting this checkbox can disable it.

Alias

The text from this box will appear in the Project Explorer as the user-defined description of the file.

Makefile Options

Sets the string which can be used in the makefile by means of the %FileOptions macro. This string represents additional parameters, relevant only to a particular file. This way you can define compiler options specific to a particular file that will be automatically built into the makefile. Makefile options can be set only for files registered to DAC as C or ASM files.

Properties (Windows)...

Displays Windows file properties.

Refresh Project Explorer

Updates Project Explorer contents.


Copyright 1993-2017, RistanCASE GmbH