"File" Menu

File menu commands enable you to execute the basic operations with files:

File menu commands

Shortcut keys associated with menu items depend on the currently active keyboard layout.

New     New command icon

The New command represents the standard function for opening a new file. This new file has a temporary name in the form of "UntitledN", where "N" is a unique number.

Open...      F3     Open command icon

The Open command opens the new Editor with the file chosen using the standard dialog box.

Close     Alt+F3

The file in the Editor will be compared with a corresponding file on the disk. If any differences exist, DAC gives you the possibility to save the file.

Save     Ctrl+S     Save command icon

The Save command enables you to save the file in the currently active window to the disk. If the file is new, with a temporary name, this command allows the possibility of renaming the file.

Save As...

Opens the standard Save As dialog box for entering a new name of the file where the complete contents of the active window will be saved. The active window can be any one of the DAC interface windows: the active pane of the Message Logs, the active window or the active pane of the Editor, the active Graph, Flowchart or Software Metrics window (WMF Format).

Save All     F4      Save command icon

The Save All command enables you to save all Editor Files, Browser or Software Metric Reports or Message Logs.

Open command icon

Format...

The Format command formats the file chosen using the standard Open dialog box. Before the formatting begins, a backup file is created, and when it is finished the Editor with the formatted file is opened.

Page and Printing Setup...

 

Print Preview

To preview your file or report, choose Print Preview command.

Print...      Ctrl+P      Print command icon

To print your file or report, choose Print command

Options for Active Window

Opens Options corresponding to the active window (Editor, Browser, Flowchart, Graph, Bar, Column, Pie, Radar, Table, ...).

Configuration Files

Configuration Files submenu

Keyboard Definition File

The Keyboard Definition File command opens an Editor with the .EML file corresponding to the active keyboard layout. .EML source text files are supposed to be in the folder in which the active .KYB file is located.

Compiler Preinclude File

The Compiler Preinclude File command opens an Editor with the compiler preinclude file, defined in Compiler options. "Compiler"

Assembler Preinclude File

The Assembler Preinclude File command opens an Editor with the Assembler preinclude file, defined in Assembler options. "Assembler"

Makefile Generator Template File

Opens an Editor with the Makefile generator template file, defined in Makefile Generator options. "Options"

User-Defined Actions Template File

The User-Defined Actions Template File command opens an Editor with the UDA template file. "Options"

Naming Convention Rules Definition File

Opens an Editor with the Naming Convention Rules Definition File, defined in Static Code Analysis "Options"

Project file

Opens a new Editor with the active project configuration file. The project parameters can be adjusted, but the recommended and easier way to do this is to use the Options menu commands.

Visual Configuration File

Opens a new Editor with the active project configuration file. The project parameters can be adjusted, but the recommended and easier way to do this is to use the Options menu commands.

Version Control Support INI File

The VCS Support INI File command opens an Editor with the open VCS support INI file which corresponds to the currently chosen Version Control System. You can adjust Version Control parameters there, but it is recommended that this should be done by using the Version Control System command in the Options menu. "Options"

Exit     Alt+F4

Carrying out the Exit command enables you to quit DAC. The current arrangement of open windows and their contents, if configured in Options > Project / Miscellaneous", will be saved for the next project opening. On quitting DAC, you will be asked whether the changed files in the Editor are to be saved.

Recently Used File List

Located below the Exit command, it contains a list of the files most recently used in Editor. Clicking a file name will open an Editor with the selected file.


Copyright 1993-2017, RistanCASE GmbH