Project Explorer

Overview

Being an intuitive and simple (Explorer-like) interface, DAC manages your projects. It facilitates adding and removing files from the project, as well as their handling and organization. Furthermore, you can view messages and data from Static Code Analysis, messages from Compiler, Linker, Make and others tools, the status from Version Control System and so on.

Project Explorer is grounded on the principles of Project Root and Referential Project Root. Although it is possible to add an arbitrary file to a DAC project, files located in the Project Root are easier to handle and display (Options > Project / Directories / Project Root). Everything in your project not defined by an absolute path is regarded as relative to the Project Root. Teamwork also benefits from the option in which the developer holds not the complete source (saving disk space), but only files necessary for the completion of the current task. The referential project version can be located in a shared place specified in the project (Options > Project / Directories / Referential Project Root). All files which do not exist relative to the Project Root are searched for as relative to the Referential Project Root. Along with the definition of the Referential Project Root, there is the possibility of differentiating these files from other files by their extension (for example, ".C" = ".CR"), so that a particular file is searched for in the following order:

1. Relative to the Project Root with the original extension.
2. Relative to the Project Root with the referential extension.
3. Relative to the Referential Project Root with the original extension.
4. Relative to the Referential Project Root with the referential extension.

The Project Explorer is divided into three views:

The Explorer view simulates Windows Explorer and supplies you with additional information on directories containing project files. Thus, generating new projects is facilitated and the surveying of complex file systems improved.

The Folder view shows only project relevant directories, thus eliminating the need to search for them in the file system. On the other hand, once the project has been generated, there is no need to go through the file system in search of project-relevant files, since everything is within easy reach and tied to very useful information. It is already possible to introduce aliases like long file names or file descriptions in this view.

The Logical view enables you to make better organization of existing projects without requiring changes in their basic structure. A large number of projects being maintained or further developed today have their beginnings in the 8.3 name length system. Some of them have long since outgrown the initially planned borders and many file and folder names have in the meantime become "wrong". The above mentioned problems can be overcome by applying the Logical view. In short, the Logical view is a filter you can position between the real project organization, which cannot be changed (restrictions of the Version Control System) and your own notion of ideal organization (hierarchy and names). This filter can depend not only on the project, but on you as well. Before you define your aliases for the files and groups and determine their hierarchy, you should familiarize yourself with these concepts via the three default groups in this view:

Default (folders) group, where each subfolder is a subgroup of this group.

Default (types) group with subgroups C Source Files, ASM Source Files, Headers, Documentation and Miscellaneous.

Default (states) group with subgroups Writable, Read Only, Changed, Not Changed, Locked and Not Locked.

It is also possible to refresh the Project Explorer contents by pressing the F5 function key (after direct use of an external program).

Each of the Project Explorer views is divided into two panes, the meaning of which will be described later on. You can rotate these panes in the Project Explorer so they assume positions which best correspond to your needs. From here on in the text, a vertical pane relation is assumed.

Explorer View

In this view folders and files are managed in way similar to the way they are managed in Windows Explorer.

Explorer View

Browse Pane

The browse pane displays a list of disks and folders. Disk and folder icons related to Referential root, if it contains alternative files, are colored yellow. Green-yellow icons are used for directories corresponding both. See Options / Project / Manager / Mark project paths.

Details Pane

Details pane displays files found in the selected folder.

Double-click the file name: if the file is editable, a new Editor will open and display the contents of the file. If not, an application associated with this file type will be launched (Windows configuration).

For explanation of icons next to the file names see "Explorer View Icons "

Folder View

This view displays project folders containing at least one file (directly or within the hierarchy). Folders below them are also shown if they contain at least one file with extension defined in Options / Project / File Types.

Folder View

Browse Pane

Only folders which contain files belonging to the project are displayed. Also, folders located under them and having at least one file with an extension defined in Options > Project / File Types are displayed as well. Project root is marked by a icon Project root. Folders containing files which do not by hierarchy belong to the Project Root folder are displayed at the main level. Folder names are listed together with their descriptions (aliases), depending on the currently selected options.

Details Pane

This view is similar to the one on the details panel of Explorer view. Unlike Explorer view, which displays all files just like Windows Explorer, this view displays only files with extensions defined in Options > Project / File Types, but it also displays files which are defined in the project but are not available. The file names are listed together with their descriptions (aliases), depending on the currently selected options.

For explanation of icons next to the file names see "Folder View Icons "

Logical View

Logical View

Browse Pane

The browse pane displays logical groups and their files. One or more groups or files may be defined within each group. A filter (File types) may be defined for each group thus precisely determining which files are automatically included within the group when a file is added to the project. To set a filter for a user-defined group, on the shortcut menu select the DAC Properties option.

Default (types, folders, and states) groups and icons representing their sub-groups Sub-group icon. They cannot be changed or removed but can be suppressed in Options > Project / Manager. Whenever files are added to the project, they are automatically assigned to Default groups.

The Default (folders) group contains all project files arranged in folders in the same way as in the Folder view. The Project Root group with files and subfolders (in this case, copied in groups) containing project files is located under the Default (folders) group. Displayed beneath the Project Root are the groups which contain project files. These groups are displayed as folders within which the project files are displayed. Besides project files, header files which do not belong to the project, but are directly or indirectly included by a file that belongs to the project are also displayed here.

The Default (types) group contains all project files arranged in groups depending on the file type (extension). DAC file types are defined a dialog box on the Options > Project / File types submenu.

The Default (states) group contains all project files arranged in groups depending on the file status (read-only files or read-write access), date of last modification or file lock status in the project VCS system.

The Read Only subgroup contains read-only available files, the Writable subgroup contains all others available files. The groups Changed and Not Changed are complementary, set filter date for Changed (select group, select option DAC Properties from the shortcut menu and enter the filter date), and group Changed will contain files modified after the filter date. Not Changed contains older files. Locked and Not Locked are available in Default (types) if there is a VCS assigned to the project. Files that are locked in the VCS are placed in the Locked group.

The subgroups of the Default (folders) group, which correspond to project folders are displayed in the same manner as the folders in the browse panel of the Folder view. Therefore, it is possible to display them with or without an alias, depending on the currently selected options. By choosing the DAC Properties option from the shortcut menu it is possible to change the alias of the corresponding group/folder.

For explanation of icons next to the file names see "Logical View Icons "

Logical groups and file names within the groups remain after the project has been closed data related to logical groups are saved under the same file name as the Project file but with a .DGR extension. This file is stored in the Project Root directory.

Details Pane

A display in this pane of Logical view depends on what has been selected in the browse pane:

Group

Files

In relation to the selected options, the details pane displays file names belonging to the currently selected group. Display in this view is different from that in Explorer or Folder view in that the icons displayed next to file names in the Explorer view and Folder view are not displayed here; only files belonging to the project and files included are displayed instead.

Group Properties

Shows group details such as the group name and currently active filter.

C Source Files

Symbols

Symbols defined in the currently selected file can be displayed only if static code analysis has been conducted. Switch buttons are placed above the list of symbols. Clicking a button displays the corresponding group of symbols.

There are switch buttons for selecting the following groups of symbols:

Functions Functions

Variables Variables

Constants Constants

Types Types

Macros Macros

Explanation of icons next to the symbols:

Functions Functions

Static Functions Static Functions

Library Functions Library Functions

Variables Variables

Static Variables Static Variables

Library Variables Library Variables

Constants Constants

Types Types

Macros Macros

Messages

Displays warnings, errors and fatal errors found during static code analysis and UDA.

The following information related to the selected file is displayed:

Message type

Line (number of the line which the message refers to)

Message text

Note

Above the list of messages are the buttons used to set up filters for messages. Each of the buttons stands for a group of messages (errors and warnings found by DAC static code analysis or resulting from UDA). Clicking a button displays the corresponding group of messages.

Filter buttons are as follows:

Warnings icon (blue) Filtering of warnings
Errors icon (red) Filtering of errors

Explanation of icons next to symbols:

Warnings icon (blue) Warnings
(red) Errors

Version Info

Displayed is the Version Control System file status. It is comprised of the following parameters:

Status, which can be

VCS not selected

Not in VCS

Not Locked

Locked

Lockers, list of users who have locked the file

Version labels, labels of locked versions of the file or present unlocked versions

Dependencies

A list of files directly or indirectly included by the currently selected file in the browse pane is displayed.

Properties (DAC)

File properties are displayed: file name, description (defined by Project > Properties (DAC)) and Makefile options (for C and Assembler source file type files).

Assembler Source Files

Version Info

File Version Control status is displayed: Status (whether the subject file is locked or not), Lockers (list of users who have locked the file) and Version labels.

Properties (DAC)

File properties are displayed: file name, description (defined by Project > Properties (DAC)) and Makefile options (for C and Assembler source file type files).

Header Files

Symbols

Symbols defined/declared in the currently selected file are displayed. The manner of display is the same as that of C Source Files, Symbols.

Messages

Warnings and errors found during static code analysis are displayed. Display and behavior are the same as that of C Source Files, Symbols.

Version Info

File Version Control status is displayed: Status (whether the subject file is locked or not), Lockers (list of users who have locked the file) and Version labels.

Dependencies

A list of files that directly or indirectly include the file currently selected on the browse pane is displayed.

Properties (DAC)

File properties are displayed: file name, description (defined by Project > Properties (DAC)).

Document Files

Version Info

File Version Control status is displayed: Status (whether the subject file is locked or not), Lockers (list of users who have locked the file) and Version labels.

Properties (DAC)

File properties are displayed: Description (defined by Project > Properties (DAC)).

Miscellaneous Files

Version Info

File Version Control status is displayed: Status (whether the subject file is locked or not), Lockers (list of users who have locked the file) and Version labels.

Properties (DAC)

Files properties are displayed: Description (defined by Project > Properties (DAC)).

Customizing

A wide range of options enables you to set Project Manager window appearance:

Use View > Project option to toggle Project Manager Window on and off.

Use Window > Docking View to toggle Project Manager window docking characteristics.

Use View > Rotate Panes for clockwise Browse and Details window rotation.

Use View > Swap Panes to switch Browse and Details window position.

Use View > Project Details Pane option to toggle view's right, Details window on and off.

The appearance of the DAC main window with the Project Manager window in it are displayed bellow, with the Docking View option set, the Details window rotated and positioned below the Browser and the Project Manager window dragged to the left edge of the main window work area.


Copyright 1993-2017, RistanCASE GmbH