Program Environment

Starting DAC

DAC is a 32-bit application developed for use under Windows. During Installation, the DAC Project file extension ".DCP" is associated with the DAC.EXE program. To start DAC on a desired project, simply double-click the Project file and the most recent project files will appear on the Start > Documents Windows menu. You may tune extension association in Windows Explorer in View >Folder Options > File Types.

The DAC program itself does not need any special maintenance. However, it bears mentioning that the program can start incorrectly if the Session File (.SES) is damaged. Should this happen, delete the Session File and restart the program. This file can be found in the same folder as the appropriate Project file ".DCP".

Command Line Parameters

DAC.EXE [ /p project_file_name [ ed_file1 [ ed_file2 [ ... ] ] ] ]  (old style, not longer supported)

DAC.EXE [ /ni ] [ /p project_file_name [ /f ed_file1 [ /f ed_file2 [ ... ] ] ] ]  [ /e Command ] [ /ef Command file] [/l Log file]

Should any parameter contain spaces, it must be surrounded by quotation marks.

/ni: DAC starts without intro dialog

/p <project file name>: Project will be opened in DAC

/f <source file name>: File will be opened in DAC editor

/e <command>: Execute command after start (see Commands Supported by DDE Server). Multiple commands must be separated by a ";" character.

/sf <script file>: Execute commands from script file after start (see Commands Supported by DDE Server)

Comments: Lines beginning with "//" are comments and will be ignored.
Commands: Multiple commands in one line must be separated by a semicolon ';'.

//
// DAC Script file for ...
//
Window::CloseAllWindowsTabs
Start::RebuildDatabase
Browse::GlobalFunctions
Browse::GlobalVariables
Browse::GlobalConstants
Browse::GlobalTypes
Browse::GlobalMacros
Browse
File::SaveAllBrowserWindows
File::SaveAllMessageLogs
Start::MyName
//File::Exit

/lf <log file>: Log file for /sf command.

Line: 00001 //
Line: 00002 // DAC Script file for ...
Line: 00003 //
OK: Line: 00004 Window::CloseAllWindowsTabs
OK: Line: 00005 Start::RebuildDatabase
OK: Line: 00006 Browse::GlobalFunctions
OK: Line: 00007 Browse::GlobalVariables
OK: Line: 00008 Browse::GlobalConstants
OK: Line: 00009 Browse::GlobalTypes
OK: Line: 00010 Browse::GlobalMacros
ERROR: Line: 00011 Browse
OK: Line: 00012 File::SaveAllBrowserWindows
OK: Line: 00013 File::SaveAllMessageLogs
ERROR: Line: 00014 Start::MyName
Line: 00015 //File::Exit

Examples of starting the DAC:

DAC.EXE

Starts DAC with last used project. All projects must be closed in order to adjust default settings that will be used for subsequent new projects.

DAC.EXE /p c:\myprjdir\myprj.dcp /f c:\myprjdir\mysrc.c

Starts DAC on MYPRJ project and open MYSRC.C in editor.

DAC.EXE /ni /p c:\myprjdir\myprj.dcp /e Start::GenerateMakefile;File::Exit

Starts DAC without intro dialog, opens MYPRJ project, generates makefile or it's components and exits.

Environment Variables

Environment variables defined in Windows can be made a part of various path specifications in DAC by surrounding the variable identifier with "%" characters. Apart from variables defined in the Windows environment, it is possible, in "Environment Substitutes", also to define "DAC environment variables".

If the %env_var% construct is found in DAC paths (project root directory, database directory, headers path or Macro %Env(env_var), ...) %env_var% will be replaced with the value

User Interface Basics

The DAC user interface consists of a set of windows, menus, toolbars and other elements, which give it the appearance of a modern, standard Windows application that allows you to manage DAC and your project efficiently.

Menu

The menu is an element of the DAC user interface which allows you to assign commands to the application. The menu contents as well as the state of particular commands is changed dynamically in accordance with the state of your project and the currently focused window. Use the menu in standard Windows fashion.

Toolbar

The toolbars, just like the menu, are used to assign commands to DAC but, unlike the menu, do not contain all, but only the most frequently used commands. The commands are represented by buttons with pictures and their state (enabled, disabled, checked, unchecked) changes synchronically with changes to the state of the corresponding menu command.

Main Window

The main DAC window is the frame for the overall content of the DAC user interface. The title on the title bar of the main window has the form "DAC - <name of the active project>". If the default project is active, the title is just "DAC".

There are two types of windows in DAC: document windows and docking windows.

You can change document window position and size within the main DAC window/

Docking windows, however, attach to the borders of the application window, or float anywhere on your screen. The docking windows in DAC are the Project Explorer and the Message Logs. They can also be switched to document windows view mode.

Status Bar

The status bar shows useful information and messages at the bottom of the main DAC window. When a menu command or toolbar button is selected, it displays the command description.

When DAC performs a time-consuming action, the status bar displays a description of the operation being performed.

Keyboard Shortcuts

Keyboard shortcuts offer an alternative method of performing actions for users who prefer the keyboard to the mouse. Some of the commands in DAC are assigned shortcut keys by default. Other commands do not have any default shortcut key assigned to them.

By selecting a keyboard in Options > Editor / Keyboard, shortcuts are automatically assigned to certain actions, and you can also assign shortcuts to the User-Defined Actions you create yourself.

Editor Macro Compiler

The Editor Macro Compiler (DAEMC.EXE) is a standard Windows application which affords the compilation of the Keyboard Definition File Source (.EML) to the Keyboard Definition File Binary (.KYB).

Compilation can be activated by the File > Compile and File > Compile Previous commands.

The File > Compile command opens the File dialog box, in which a .EML source file is selected for compilation.

The File > Compile Previous command compiles the most recently accessed .EML file.

The Editor Macro Compiler can be activated from DAC by the Start > Compile Keyboard Definition File command.

DACEdit Program

In the software development programs you are using there must be a need to define an "External Editor", for example in version control programs. It is not expedient to cite DAC directly in this case because a new instance of DAC would be started for each file if you were to do so. That is why the DACEdit.exe program, which, if necessary, first starts DAC and then passes on the correct commands via DDE (see "Direct Data Exchange (DDE)" in DAC Users Manual), is now at your disposal. Apart from purely editor-type commands, DACEdit can forward a multitude other commands, meaning that it can be used for DAC remote control. DACEdit and DAC communication is asynchronous, DAC Edit does not wait for the execution of commands. These commands can have the following syntax: 

DACEdit [/t time] [/p <project file name>[.dcp] [/saveall]]

DACEdit [/t time] [/f <file path> [/save|update] [/l <line>] [/c column]] 

DACEdit [/t time] [/q|h] [/e [UDA macro];[UDA action];[Menu command];[Editor macro]] 

DACEdit [/t time] [/f <file path> [/save|update] [/l <line>] [/c column]] [/fc <function>|<line>][/chg <function>][/thg <symbol>]]

Should any parameter contain spaces, it must be surrounded by quotation marks.

/n <instance name>: Name of the DAC instance (Windows title). On this way DACEdit may connect to right DAC instance if more than one DAC instances are open. On DAC side this is project name or his alias (Options > Project Explorer...").

/p <project file name>: Name of the project to be opened in DAC.

/f <filename>: Name of the file to be opened in DAC Editor. The extension has to belong to the list of editable files. If no project was opened prior to this (which is certainly highly advisable as DAC is a project-oriented tool), a default project with limited configuration possibilities will be opened. 

/l <line>: Line on which the insertion point should be positioned on opening a file.

/c <column>: Column on which the insertion point should be positioned on opening a file.

/fc <function|line>: Shows Flowchart from <function> or on <line>.

/chg <function>: Shows Call Hierarchy Graph from <function>.

/thg <symbol>: Shows Type Hierarchy Graph from <symbol> (typedef or structure). 

/e <command>: Execute command after start (see Commands Supported by DDE Server). Multiple commands must be separated by a ";" character.

/sf <script file>: Execute commands from script file after start (see Commands Supported by DDE Server)

Comments: Lines beginning with "//" are comments and will be ignored.
Commands: Commands in one line must be separated with semicolon ';'.

/lf <log file>: Log file for /sf command.

/saveall: Command for saving edited files in the Editor.

/save|update: Command for saving the currently active file in DAC, if it has been changed. To ensure compatibility with earlier versions, the alternative command /update may be used.

/q|h: Execute action in quiet mode. To ensure compatibility with earlier versions, the alternative command /h (hidden) may be used.

/t <time>: Delay time in sec after DAC start command was sent.


Copyright 1993-2017, RistanCASE GmbH