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Using DAC with Mitsubishi Tools

NOTE:

This technical note
only provides infor-
mation on how to
configure DAC to
facilitate your work
with the Mitsubishi
7900 V3.xx Tools, for
which the document
has primarily been
written. Using it as a
basis, DAC can eas-
ily be configured to
work with other Mit-
subishi tools. For fur-
ther information on
DAC, please refer to
"Development Assis-
tant for C" documen-
tation V4.0.

I Requirements
]

* DAC - V4.0.055 or later - (Development Assistant for C -
RistanCASE). The latest version, with Demo Mode license included,
can be downloaded from the following URL:
http://www.RistanCASE.com/dac/v40/dac_download.php

If you are running DAC in Demo Mode, you can easily obtain a trial
license and enjoy all the comforts of DAC for two weeks! For more
details, choose Technical Support from the Help menu.

* GNU make V3.75 or later - (Free Software Foundation). The
gmake.exe with RistanCASE improvements can be downloaded from
the following URL:
http://www.RistanCASE.com/gnu/gnu_products.php

In the following sections, it is assumed that your Mitsubishi 7900 V3.xx
tools have been installed in the "C:\Mtool" folder. In the text that follows,
this folder will be referred to as the "Mitsubishi folder." You may have to
adapt the paths used in the example provided to match your current instal-
lation paths.

Mitsubishi 7900 V3.xx tools and the GNU make utility folders have to be
in the system PATH. The GNU make should be named "gmake.exe".

It is also assumed that DAC has been installed in the "C:\Program
Files\RistanCase\Development Assistant for C" folder, which does not
have to be in the system PATH. In the text that follows this folder will be
referred to as the "DAC folder."
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Using DAC with Mitsubishi Tools

2 Configuring DAC
]

To make the most of your Mitsubishi 7900 V3.xx tools with DAC, these
are the steps to follow:

* Creating a New Project

e Configuring Working Directories

e Configuring Analysis for Symbols

e Configuring Compiler Dialect and Header Directories
¢ Configuring Assembler Dialect and Header Directories
* Adding Files to the Project

* Building the Database

e Integrating the Tools

As you progress through this technical note, you will be led through the
process of creating a new DAC project named "Samp79." The "Samp79"
example project can be found on RistanCASE's CD-ROM in the
"DAC\Technical Notes\Mitsubishi" folder, or downloaded from
RistanCASE's web site: http://www.RistanCASE.com/dac/v40/specific-
support/mitsubishi.php

Supported tools by DAC - V4.0.055 or later

Supported compilers

Mitsubishi M16C/60-20 V3.xx
Mitsubishi M16C/60-20 V4.xx
Mitsubishi M16C/80 V2.xx
Mitsubishi M16C/80 V3.xx

©2002 RistanCASE GmbH DAC-40-71-106
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Using DAC with Mitsubishi Tools

Supported tools by DAC - V4.0.055 or later (Continued)

Supported compilers

Mitsubishi 7900 V3.xx

2.1 Creating a New Project

Start DAC and choose New Project from the Project menu. Browse
through the "Smp79" subfolder of the Mitsubishi folder and enter the
project file name "Samp79". A project file will be created. The standard
project file extension is ".dcp”, so the created file will be named
"Samp79.dcp”.

New H L
Sa\u'e_in:lasmli'?9 j gl
Filz name; |Samp?8 Save I
Save as lype: IProiect file [*.dcp) j Cancel |

Figure 2.1 Creating a new project

2.2 Configuring Working Directories

On the Options menu, click Project to open the Project Options dialog
box. Use this dialog box to set project directories:

Project Options k
Directaries I File Typesl Miscellansous I

Project Root directary
I. Browse... |
Referential Project Root directony
| Browse... |
Header Directories
I Browse... |
Databaze directory
|_db Browse... |
User Help file
IC:\MTDDL\BIN\NC?Swae.hlp Brawse... |
™ Automatically add new project paths to Header directories.

Ok I Cancel | Help |

Figure 2.2 Configuring working directories
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Project Root directory

The full path is expected in the Project Root directory text box or, as a
special value, a single period character, which stands for "the directory
where the project file resides." The names of all files belonging to the
project are considered relative to the Project Root directory if the full file
path is not given. In our example, keep the single period character for the
Project Root directory.

Referential Project Root directory

If not empty, it specifies an alternative path for searching for files that
DAC fails to find in the original project path. DAC will attempt to find
files with the referential extension in the Project Root directory prior to
searching the referential Project Root directory. The specified path may
either be full or relative to the Project Root, and it may not specify a sub-
folder in the Project Root directory tree. In this example it should be left
empty.

Header Directories

You should specify paths to all header directories used in the project. The
paths are separated by a semicolon.

Database directory

It allows the Symbols and Software Metrics database files folder to be set.
The path in question can be absolute or relative to the Project Root direc-
tory. If the Database directory is left unspecified, the Symbols and Soft-
ware Metrics database files are created in the Project Root directory along
with source and other files. It is recommended that you should specify the
Database directory, to keep these files from mixing. Enter " db" in the
box.

User Help file

It enables you to set the User Help file, for example, the Compiler Help
file. The shortcut key for the User Help file can be set in the Keyboard
definition file (default CTRL + SHIFT + F1). Browse through the "Bin"
subfolder of the Mitsubishi folder and select the "Nc79wae.hip" help file.
This will give you an entry point for Mitsubishi Windows Help.

2.3 Configuring File Types

On the Options menu, click Project and select the File Types tab. Here
you can set file extensions for the basic project file types. A file type
extension list consists of up to 10 file extensions separated by a white

space or the "." character. To ensure maximally efficient use of Mitsubishi
7900 V3.xx tools, fill in the boxes as shown in the following picture:

©2002 RistanCASE GmbH DAC-40-71-106
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Project Oplions HE k
Directories  File Types I Miscellansous I
— Referential
L Source file Original ~ Fef.
B —
Agszembler Source file
|.a73 [ [
Header file
|.h. inc I I
Document file
I.doc. it I I
Text file
I.dc:p. tat.drmt kpl. map. stk I I

] I Cancel | Help |

Figure 2.3 Configuring File Types

C Source file

Files with one of the extensions listed in this box will be considered C
source files. Header file extensions should not be defined within this field.
Enter ".c" in the box.

Assembler Source file

Files with one of the extensions listed in this box will be considered
included Assembler files. Module file extensions should not be defined
within this field. Enter ".a79" in the box.

Header file

Files with one of the extensions listed in this box will be considered
included C header files. Module file extensions should not be defined
within this field. Enter ".h.inc" in the box.

Document file

Files with one of the extensions listed in this box will be considered docu-
ment files. Enter ".doc.rtf" in the box.

Text file

Files with one of the extensions listed in this box will be considered edit-
able (text) files. If files without extensions are to be considered editable,
the list ends with a period ".". Enter ".dcp.txt.dmt.tpl.map.stk" in the box.

Referential pairs

Fields for entering alternative (referential) extensions are located in this
area. The original extension is entered in the Original column, while the
alternative extension is entered in the Referential column. Up to five orig-
inal / alternative pairs can be set. If opening the file with the original

DAC-40-71-106
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extension fails, DAC will attempt to find and open the file with the identi-
cal name and the alternative extension.

2.4 Configuring Analysis for Symbols

For this example you may need to configure Analysis for Symbols
Options from General and C Source sections.

2.4.1 General

On the Options menu, click Analysis for Symbols, and then click the
General tab to open the following dialog box:

Analysis for Spmbols Options L

C Saurce | W arnings | MISRA C Compliance | Sumbal Marme Checking I

— W arning: —Header
" Dizabled ¥ Check headers on update
" Enabled V' Use default szarch
™ Digabled for all headers ™ Use search paths
i+ Disabled for standard library headers W Lse VaRAMS dives
¥ Show unresobved extemals - Stop After
¥ Show unuzed spmbols I_D Emars
V' Globals/statics used in one
module/function I_D \warnings

Enviranment substitutes

[ |
[ -]

Ok I Cancel | Sl | Help |

Figure 2.4 General Analysis for Symbols Options

Environment substitutes

Environment variables defined in Windows can be made a part of various
path specifications in DAC by enclosing the variable identifier in "%"
characters. Apart from variables defined in the Windows environment, it
is possible, in Environment substitutes, also to define "DAC environ-
ment variables" in the form of:

env_var=env_string

If the %env_var %construct is found in DAC paths (project root directory,
database directory, include path, %Env(env_var), ...) %env_var %will be
replaced with an env_stri ng.

These substitutions are also necessary if the environment variables of
your development environment have been set only in the DOS window in
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which you build project binaries. As the variables are not known at Win-
dows level, if you intend to use them, you will have to define them in
DAC, in Environment substitutes.

For a detailed explanation of other options in the General tab please con-
sult DAC help.

2.4.2 C Source

On the Options menu, click Analysis for Symbols, and then click the C
Source tab to show the following dialog box:

Analysis for Spmbols Options L

General C Source | warnings I MISRA C Compliance I Symbol Mame Checking I

‘ b ax identifier length I Kl [™ Special table processing ‘

Preproceszar
Defines/Control file

I Browsze. .. |

I™ Mested comments W C++ comments [ Tradiional [ lgnore #line

ok I Cancel | Spply | Help

Figure 2.5 C Source Analysis for Symbols Options

Maximum identifier length

This is the number of significant characters in the identifiers. The remain-
ing characters are ignored. The default value is 31.

Special table processing

It determines the treatment of arrays of pointers to functions in the analy-
sis. If this option is selected, such variables are treated as functions, other-
wise, they are treated in the usual way (default).

Defines / Control file

It determines the list of macro definitions to be set at the beginning of the
module preprocessing. This box may contain the control file name (with
absolute or relative path in relation to the project root) with the prefix @.
The prefix @ is also used in the Project file ".dcp"” to specify included
files. Therefore, you should avoid using the character @ at the beginning

DAC-40-71-106
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of the names of files and folders that are to be used in the project. Control
file lines beginning with -i or -I subsequently contain the list of directories
for searching for #i ncl ude files, separated by a semicolon. Control file
lines beginning with -d or -D subsequently contain the list of macro defi-
nitions, as described in the previous paragraph. The remaining control file
lines are ignored.

Nested comments

It allows proper recognition of nested C style comments, for example / *
[* o0 **].

C++ comments

It determines if C++ comments (beginning with "//") are to be recognized
while analyzing the source code.

Traditional

It determines if the pre-ANSI preprocessor is to be used. For the tradi-
tional preprocessor, a comment is equivalent to nothing, while for the
ANSI preprocessor it is a white space. The traditional preprocessor does
not delete comments within the #def i ne directive, it does not recognize
"#" and "##" operators, and requires an initial "#" in a directive at the
very beginning of the line. It allows specification f oo() if'a macro f oo
takes a single argument, and permits a macro to be expanded recursively.

Ignore #line

It determines that the #l i ne preprocessor directive be ignored.

2.5 Configuring Compiler Dialect and Header
Directories

An additional path configuration must be performed to specify the loca-
tion of the Mitsubishi C compiler library header file (needed for DAC
symbol analysis). On the Options menu, click Compiler to show the
Compiler Options dialog box. This dialog box contains options which
enable you to set C source code analysis parameters:

©2002 RistanCASE GmbH DAC-40-71-106
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Compiler Options L

Compiler I

—Source
IMitsubishi 7900 W3k j Help |
LCompiler header directories
|E:\MTDDL\INC?S Browse. .. |
Preinclude header file
IMitsubishi 7003wk Browse... |

Ok, I Cancel Sl Help

Figure 2.6 Compiler Options

Source

The supported C dialects of the C language used in the active project can
be selected in this box. In the "Samp79" example project the Mitsubishi
7900 V3.xx dialect is used.

Compiler header directories

It enables you to set the list of directories which are to be searched for the
files named using the " #i ncl ude" directive. Different directories within a
list are separated by a semicolon character. Only listed directories are
searched for files whose names are written enclosed in brackets ("<" and
">"). The search for files whose names are written enclosed in quotation
marks ("") starts in the folder in which the source file containing the
"#include" directive resides.

The list of header directories can be assigned to a file. In that case, the
Compiler header directories box contains the file name (with absolute
or relative path in relation to the Project Root) with the @ prefix. The
directories listed in the file are separated by a semicolon or a new line (no
semicolon necessary). The prefix @ is also used in the Project file ".dcp”
to specify included files. Therefore, you should avoid using the character
@ at the beginning of the names of files and folders that are to be used in
the project.

The path of the Compiler libraries for the used CPU should be defined as
the "Inc79" subfolder of the Mitsubishi folder.

DAC-40-71-106
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Preinclude header file

It enables you to set the name of the file which will be included automati-
cally at the beginning of every C source module during the analysis, as if
the #i ncl ude directive containing the name of the file in question
enclosed in quotation marks ("") was present in the first line of the ana-
lyzed source code. The preinclude file is used to specify predefined mac-
ros, variable and function declarations for a particular compiler which are
not set by default in DAC analysis. The one corresponding to the Mitsub-
ishi 7900 V3.xx compiler has been selected here: "Mitsubishi 7900
V3.xx.h". This file contains declarations of Mitsubishi 7900 V3.xx C
Compiler predefined macros. It is located in the "Preinclude Files" sub-
folder of the DAC folder. To adapt this file to your needs, on the File
menu, point to Configuration Files and click Compiler Preinclude File.

2.6 Configuring Assembler Dialect and Header
Directories

Assembler support for Mitsubishi has not been released yet. On the
Options menu, click Assembler, and then in the Source box select
<none>.

2.7 Adding Files to the Project

In the Project Window the Explorer View replaces the Windows
Explorer and supplies you with plenty of information on directories con-
taining project files. It also gives you the possibility of adding files to the
project. All files needed to run the "Samp79" example will now be added
to the project.

-10 -

©2002 RistanCASE GmbH DAC-40-71-106



DAE V4.9

Using DAC with Mitsubishi Tools

In the Explorer View, add each file separately by selecting each one and
adding it to the project.

3 oo |
=-{E Mool ;I
{27 Bin
{27 Inc7a
{27 Lib79
27 Manual
425 Smp7d
I Se7d [ ]
(I3 Startup
-3 Suppart
LI Nc79wa
w3 Tmp ;I
MName I Sizel Tvpe I Maodified
makefile.doz 804 DOS File 30.07.1958 16:40
w nortl.artd 452KB  A739File 09.11.1999 13:06
W samp7d.c 284KE  C Source File 18.03.2002 02:43
« Samp?9.dcp  1.82KE  Development Assistant for C Project  06.08.200217:12
Sample.a7d  1.91KB A7 File 24.11.1933 1812
= zect?Linc 3.BEKE  INCFile 27.01.2000 16:26
stuct.ard 152KB  A73Fie 241119531812

Figure 2.7 Project Window - Explorer View (Undocked mode)

Another alternative is to browse through the Mitsubishi folder, and select
the "Smp79" subfolder. Right-click and choose Add to project. All file
types configured in the previous section Configuring File Types, are now
added to the project. Remove the files not belonging to the project.

2.8 Building the Database

Development Assistant for C provides the static code analysis of C and
ASM source files, and generates various data based on the results.

The analysis of the project source files and the generation of the database
are divided into two phases: the analysis of individual program modules
and the generation of data on global symbols usage. The results of the
analysis are saved in database files on the disk, allowing them to be used
in DAC later on. You can choose between the unconditional analysis of all
project files and the analysis of changed source files only, using the Build
Database and the Update Database commands from the Start menu,
respectively. The Update Database command will optionally check if the
include files used in program modules have been changed as well.

To build the database in the "Samp79" example, on the Start menu click
the Build Database command. This command performs the uncondi-
tional analysis of all project files and creates a database containing infor-
mation on the analyzed source code. The errors and warnings detected
during this operation are displayed in the Messages window as illustrated
(for the "Samp79.c" sample file):

DAC-40-71-106

©2002 RistanCASE GmbH -11 -



Using DAC with Mitsubishi Tools

Analysis for Symbols | MISRA C Compliance |

I File: | Line | Message | Mote | x
* samp/dc 39 Warhing 311: main: Mixed old stule and AMSI functioh declarations
+ sampidc B3 | Warning 311: indicate: Mized old stule and AMS| function declarations
#* zampidc 24 Wwaming 302 tal_jicon: Global identifier defined and uged in only one module
#* sampfac 24 | Warning 302 up_down: Global identifier defined and used in only one module
* sampfac 24 | Warning 302; tall_mode: Global identifier defined and used in only one module
* zampiac B3 | warning 302 indicate: Global identifier defined and uzed in only one module
* sampidc B7 | Wwarning 307: timer_alint: |dewtifier never used
+ sampidc 25 | warning 302 timer_all: Global identifier defined and used in only one module
#* zampidc 24 Waming 302 cnt_start Global identifier defined and uzed in only one module
#* sampfac 23 Warning 302 portl: Global identifier defined and used in only one moduls
* sampfac 23| Warning 302 p0_dir. Global identifier defined and used in only one module

Figure 2.8 Messages Window - Analysis for Symbols tab (Undocked mode)

Once the analysis of all project files has been completed, the new data-
base file containing the information on global symbols is created. Please
refer to the DAC manual for further information on how symbols infor-
mation can be used.

In the DAC Project Window, select the Logical View tab and unfold
fields to get an overview of your project:

ERERIE

=+ Samp7d

213 Default (folders]
B3 Project Roat
e[ Mitsubishi 7300 v 3.0 drt
----- 3 ncr0.a79
----- [ [sampFae
----- [3 Samp79.dep
. [q sect?9ine
B3 DriveC
B3 Mool
B3 Inc79

[ stdioh
=3 Pragram Files

B3 RistanCASE

E|C] Development Assistant for C
E1-{Z3 Preinclude Files

------ [ Mitsubishi 7900 v3.xxh

-3 Default [types]
F-{C3 Default [states)

Symbols I Messagesl Yersion Infol Dependenciesl [LI_’I

LA

Line | Marie |
24 cntb_start
63 indicate
33 main
23 pO_dir
23 port
24 tal icon
24 tal_mode
25 timer_al
A7 timer_alint
24 up_down

=] <]=0=] <] =] ] ]

Figure 2.9 Project Window - Logical View (Undocked Mode)
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]
3 Integrating the Tools
]

3.1 User-Defined Actions (UDA) Setup

To integrate Mitsubishi 7900 V3.xx tools and GNU make into DAC IDE,
on the Option menu, click User-Defined Actions, and then click the
Start Menu Actions tab.

Now check the Use compiler template check box. By selecting this
option, you have decided on what is probably the most common manner
of using Mitsubishi tools. The action is contained in the "Mitsubishi 7900
V3.xx.tpl" file located in the "UDA Templates" subfolder of the DAC
folder. You can edit it and adjust it to your needs. RistanCASE would
appreciate your sharing additional features and ideas with us. Now click
OK.

DAC-40-71-106 ©2002 RistanCASE GmbH -13 -
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User-Defined Actions [ 7] L

Start Menu Actions | Wersion Control Menu Actions I Shartcuts I Command Shell I

— Meru
Chompile File - New I [DElete | Eenamel
Compile &4 Files
ELink All Files

M ake Project i [ I

— Show output data in

U [V Use compiler
template

& WG DS Frompt. ) U DS Eutputwindow 0 Doani shov autput

) TEwt I

| Eicture IMitsubishi_c:ompile_file.bmp Erovse.

—Action scrpt

%R 4[Project contains neither C nor 45 source files.]
(%if[%CFile %R 2% True) %R 2[%False])
if(AemFile, 2R3 T ue) 2R 3(%F alze))
ZifEMot(%R 2R 3) ZMessage(ZR4)% Cancel]

%R 4|Pleaze zelect C zource or ASM zource file.)
CER1[ZCurFile]

ER2(%Fale)

4 |

Ok I Cancel | Sl | Help |

= o L

Figure 3.1 User-Defined Actions - Start Menu Actions

On the View menu, point to Toolbars, and then click User-Defined
Actions. Five UDA buttons should now appear on the DAC toolbar, and
the items Compile File, Compile All Files, Link All Files, Make
Project, and Build Project on the Start menu. On the toolbar, appearing
from left to right, the UDA buttons are:

User Defined [ x]

Figure 3.2 UDA toolbar (undocked mode)

+ Compile File @
» Compile All Files @
+ Link All Files @
* Make Project Iﬂl
* Build Project

3.2 Makefile Template Setup

In order to completely define the Compile File, Compile All Files, Link
All Files, Make Project, and Build Project UDA with the gmake utility,
a project makefile must be provided. This file should have the same name
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INFO:

You inevitably have
to make the neces-
sary customizations
of the appropriate
file for their compiler.
Follow the direc-
tions given in the
template file and
consult your com-
piler tools literature if
and when neces-

sary.

NOTE:

On every start of the
Build or Update the
Database com-
mand from the Start
menu, DAC will
automatically check
if the makefile needs
to be regenerated.

as the current project and the extension ".mak". It can be edited manually
or generated automatically.

The template files are generally used to define all the necessary macros,
commands, rules, and so on, which facilitate automatic project makefile
generation by means of the Makefile Template Macro Language instruc-
tions expansion.

Since manual editing is a very tedious and error-prone process, an exam-
ple makefile template "Mitsubishi 7900 V3.xx.dmt" has been provided in
the "Makefile Generator Templates" subfolder of the DAC folder.

Another file that should be customized to reflect the properties of a target
system on which a program is to be executed is the linker command file.
If the "Mitsubishi 7900 V3.xx.dmt" makefile template is expanded, the
linker command file will automatically be generated along with the make-
file. The template file section responsible for the linker command line file
generation is at the end of the template and is commented.

To enable automatic makefile generation, do the following:

»  Copy the file "Mitsubishi 7900 V3.xx.dmt" from the "Makefile Gener-
ator Templates" subfolder of the DAC folder to the "Smp79" subfolder
of the Mitsubishi folder.

» Customize "Mitsubishi 7900 V3.xx.dmt" to your needs.

*  On the Options menu, click Makefile Generator, and then select
Generate makefile or its components.

* In the Makefile template box enter "Mitsubishi 7900 V3.xx.dmt" or
use the Browse button to find it.

+ Click OK.

* On the Start menu, click Generate Makefile. The makefile for your
project will be generated automatically.

M akefile Generator Options HE L
V' Generate makefile o itz components
I ak efile template
|Mitsubishi TA00 Y 3. dmt Browsze... I
DK I LCancel I Help |
R

Figure 3.3 Makefile Generator Options

The report of the automatic project makefile generation process is dis-
played in the Messages window under the Makefile Generator tab. After

DAC-40-71-106
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the project makefile has successfully been created, you can use the Link
All Files, Make Project, or Build Project UDA to generate the
"Samp79.x79" file.

The generated "Samp79.mak” file can be opened for inspection. Please,
bear in mind that any changes made in it would be overwritten as soon as
any of the following actions from the Start menu is performed: Build
Database, Update Database or Generate Makefile. This means that if
any changes to makefiles are to be made, the make template file should be
edited instead.

DAC UDA handles compiler error reports and displays them in the Mes-
sages window under the Compiler Messages or Linker Messages tab,
depending on the UDA performed.

3.3 Using Mitsubishi 7900 v3.xx Tools by Default

If you want your newly created project files to automatically inherit the
proper setup for Mitsubishi 7900 V3.xx tools, you should also customize
the default DAC project file "dac.dcp”, which is located in the "Program”
subfolder of the DAC folder.

-16 -
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