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Using DAC with Microchip Tools

NOTE:

This technical note
only provides infor-
mation on how to
configure DAC to
facilitate your work
with the Microchip
C17 V2.x Tools, for
which the document
has primarily been
written. Using it as a
basis, DAC can eas-
ily be configured to
work with other
Microchip tools. For
further information
on DAC, please refer
to "Development
Assistant for C" doc-
umentation V4.0.

I Requirements
]

* DAC - V4.0.055 or later - (Development Assistant for C -
RistanCASE). The latest version, with Demo Mode license included,
can be downloaded from the following URL:
http://www.RistanCASE.com/dac/v40/dac_download.php

If you are running DAC in Demo Mode, you can easily obtain a trial
license and enjoy all the comforts of DAC for two weeks! For more
details, choose Technical Support from the Help menu.

* GNU make V3.75 or later - (Free Software Foundation). The
gmake.exe with RistanCASE improvements can be downloaded from
the following URL:
http://www.RistanCASE.com/gnu/gnu_products.php

In the following sections, it is assumed that your Microchip tools tools
have been installed in the "C:\mcc" folder. In the text that follows, this
folder will be referred to as the "Microchip folder." You may have to
adapt the paths used in the example provided to match your current instal-
lation paths.

Microchip tools and the GNU make utility folders have to be in the sys-
tem PATH. The GNU make should be named "gmake.exe".

It is also assumed that DAC has been installed in the "C:\Program
Files\RistanCase\Development Assistant for C" folder, which does not
have to be in the system PATH. In the text that follows this folder will be
referred to as the "DAC folder."
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Using DAC with Microchip Tools

2 Configuring DAC
]

To make the most of your Microchip C17 V2.x tools with DAC, these are
the steps to follow:

* Creating a New Project

e Configuring Working Directories

e Configuring Analysis for Symbols

e Configuring Compiler Dialect and Header Directories
¢ Configuring Assembler Dialect and Header Directories
* Adding Files to the Project

* Building the Database

e Integrating the Tools

As you progress through this technical note, you will be led through the
process of creating a new DAC project named "Ad." The "Ad" example
project can be found on RistanCASE's CD-ROM in the "DAC\Technical
Notes\Microchip" folder, or downloaded from RistanCASE's web site:
http://www.RistanCASE.com/dac/v40/specificsupport/microchip.php

Supported tools by DAC - V4.0.055 or later

Supported compilers

Microchip C17 V2.x

2.1 Creating a New Project

Start DAC and choose New Project from the Project menu. Browse
through the "Ad" subfolder of the Microchip folder and enter the project

©2002 RistanCASE GmbH DAC-40-71-114
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Using DAC with Microchip Tools

file name "Ad". A project file will be created. The standard project file
extension is ".dcp”, so the created file will be named "Ad.dcp”.

New 2] L
Save jn: I 3 Aad j (] I‘j‘ '
Filz name; |Ad Save I
Save as hype: IProiect file [*.dzp) j Cancel |

Figure 2.1 Creating a new project

2.2 Configuring Working Directories

On the Options menu, click Project to open the Project Options dialog
box. Use this dialog box to set project directories:

Project Options h

Directaries I File Typesl Miscellaneous I

Project Boot directary

I. Browse... |
Fieferential Project R oot directory

| Browse... |
Header Directories

I Browse... |
Databaze directory

|_db Browse... |
User Help file

|E:\MEE\doc\c1 Flib1.hlp Brawsze... |

I Automatically add new project paths to Header directories.

ak. I Cancel | Help |

Figure 2.2 Configuring working directories

Project Root directory

The full path is expected in the Project Root directory text box or, as a
special value, a single period character, which stands for "the directory
where the project file resides." The names of all files belonging to the
project are considered relative to the Project Root directory if the full file
path is not given. In our example, keep the single period character for the
Project Root directory.

DAC-40-71-114
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Using DAC with Microchip Tools

Referential Project Root directory

If not empty, it specifies an alternative path for searching for files that
DAC fails to find in the original project path. DAC will attempt to find
files with the referential extension in the Project Root directory prior to
searching the referential Project Root directory. The specified path may
either be full or relative to the Project Root, and it may not specify a sub-
folder in the Project Root directory tree. In this example it should be left
empty.

Header Directories

You should specify paths to all header directories used in the project. The
paths are separated by a semicolon.

Database directory

It allows the Symbols and Software Metrics database files folder to be set.
The path in question can be absolute or relative to the Project Root direc-
tory. If the Database directory is left unspecified, the Symbols and Soft-
ware Metrics database files are created in the Project Root directory along
with source and other files. It is recommended that you should specify the
Database directory, to keep these files from mixing. Enter " _db" in the
box.

User Help file

It enables you to set the User Help file, for example, the Compiler Help
file. The shortcut key for the User Help file can be set in the Keyboard
definition file (default CTRL + SHIFT + F1). Browse through the "doc”
subfolder of the Microchip folder and select the "c17lib1.hlp" help file.
This will give you an entry point for Microchip Windows Help.

2.3 Configuring File Types

On the Options menu, click Project and select the File Types tab. Here
you can set file extensions for the basic project file types. A file type
extension list consists of up to 10 file extensions separated by a white

space or the "." character. To ensure maximally efficient use of Microchip
C17 V2.x tools, fill in the boxes as shown in the following picture:

©2002 RistanCASE GmbH DAC-40-71-114
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projectopions @I
Directories  File Types I Miscellansous I

— Referential
C Source file Original ~ Fef.
[c .
Azzembler Source file
I.asm I I
Header file
|-h [ [
Dacument file
I.doc. iitf I I
Text file
I.dc:p. bt err |z kr.dmk. bpl. mak, I I

] I Cancel | Help |

Figure 2.3 Configuring File Types

C Source file

Files with one of the extensions listed in this box will be considered C
source files. Header file extensions should not be defined within this field.
Enter ".c" in the box.

Assembler Source file

Files with one of the extensions listed in this box will be considered
included Assembler files. Module file extensions should not be defined
within this field. Enter ".asm" in the box.

Header file

Files with one of the extensions listed in this box will be considered
included C header files. Module file extensions should not be defined
within this field. Enter ".h" in the box.

Document file

Files with one of the extensions listed in this box will be considered docu-
ment files. Enter ".doc.rtf" in the box.

Text file

Files with one of the extensions listed in this box will be considered edit-
able (text) files. If files without extensions are to be considered editable,
the list ends with a period ".". Enter ".dcp.txt.err.Ist.Ikr.dmt.tpl.mak" in the
box.

Referential pairs

Fields for entering alternative (referential) extensions are located in this
area. The original extension is entered in the Original column, while the
alternative extension is entered in the Referential column. Up to five orig-

DAC-40-71-114
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Using DAC with Microchip Tools

inal / alternative pairs can be set. If opening the file with the original
extension fails, DAC will attempt to find and open the file with the identi-
cal name and the alternative extension.

2.4 Configuring Analysis for Symbols

For this example you may need to configure Analysis for Symbols
Options from General and C Source sections.

2.4.1 General

On the Options menu, click Analysis for Symbols, and then click the
General tab to open the following dialog box:

Analysis for Symbols Options L

General | C Source I warnings I MISRA C Compliance I Symbol Mame Checking I

—'Warning —Header
" Dizabled ¥ Check headers on update
" Enabled ¥ s default search
" Digabled for all headers ™ Use search paths
¢ Digabled for standard library headers [ Use VARAMS dives
v Show unresolved externals - Stop After———————————
¥ Show unuzed spmbils I_D Erars
W Globals/statics uzed in one
module/function I_D warnirigs

Enviranment substitutes

I

ok I Cancel | Spply | Help |

Figure 2.4 General Analysis for Symbols Options

Environment substitutes

Environment variables defined in Windows can be made a part of various
path specifications in DAC by enclosing the variable identifier in "%"
characters. Apart from variables defined in the Windows environment, it
is possible, in Environment substitutes, also to define "DAC environ-
ment variables" in the form of:

env_var=env_string

If the %env_var %construct is found in DAC paths (project root directory,
database directory, include path, %Env(env_var), ...) %env_var %will be
replaced with env_stri ng.
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These substitutions are also necessary if the environment variables of
your development environment have been set only in the DOS window in
which you build project binaries. As the variables are not known at Win-
dows level, if you intend to use them, you will have to define them in
DAC, in Environment substitutes.

For a detailed explanation of other options in the General tab please con-
sult DAC help.

2.4.2 C Source

On the Options menu, click Analysis for Symbols, and then click the C
Source tab to open the following dialog box:

Analysis for Spmbols Options L

General C Source | W arnings | MISRA C Compliance | Sumbal Marme Checking I

‘ M ax identifier length I i [™ Special table processing ‘

Freproceszor

Defines/Contral file

I Browsze... |

[T Mested comments W C++ comment: [ Tradiional [ lanore Hline

Ok I Cancel | Sl | Help

Figure 2.5 C Source Analysis for Symbols Options

Maximum identifier length

This is the number of significant characters in the identifiers. The remain-
ing characters are ignored. The default value is 31.

Special table processing

It determines the treatment of arrays of pointers to functions in the analy-
sis. If this option is selected, such variables are treated as functions, other-
wise, they are treated in the usual way (default).

Defines / Control file

It determines the list of macro definitions to be set at the beginning of the
module preprocessing. This box may contain the control file name (with
absolute or relative path in relation to the project root) with the prefix @.

DAC-40-71-114

©2002 RistanCASE GmbH -7-



Using DAC with Microchip Tools

The prefix @ is also used in the Project file ".dcp"” to specify included
files. Therefore, you should avoid using the character @ at the beginning
of the names of files and folders that are to be used in the project. Control
file lines beginning with -i or -1 subsequently contain the list of directories
for searching for #i ncl ude files, separated by a semicolon. Control file
lines beginning with -d or -D subsequently contain the list of macro defi-
nitions, as described in the previous paragraph. The remaining control file
lines are ignored.

Nested comments

It allows proper recognition of nested C style comments, for example / *
[* o0 %

C++ comments

It determines if C++ comments (beginning with "//") are to be recognized
while analyzing the source code.

Traditional

It determines if the pre-ANSI preprocessor is to be used. For the tradi-
tional preprocessor, a comment is equivalent to nothing, while for the
ANSI preprocessor it is a white space. The traditional preprocessor does
not delete comments within the #def i ne directive, it does not recognize
"#" and "##" operators, and requires an initial "#" in a directive at the
very beginning of the line. It allows specification f oo() if a macro f oo
takes a single argument, and permits a macro to be expanded recursively.

Ignore #line

It determines that the #| i ne preprocessor directive be ignored.

2.5 Configuring Compiler Dialect and Header
Directories

An additional path configuration must be performed to specify the loca-
tion of the Microchip C17 V2.x compiler library header file (needed for
DAC symbol analysis). On the Options menu, click Compiler to open
the Compiler Options dialog box. This dialog box contains options
which enable you to set C source code analysis parameters:

©2002 RistanCASE GmbH DAC-40-71-114
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compieroppions g

Compiler |

— Source
| Microchip C17 2.5 =l Help |
LCompiler header directories
|CAMCCHh Brawse... |
Preinclude header file
|Preinclude\Microchip C17v2ah Browse. . |

Ok I Cancel Sl Help

Figure 2.6 Compiler Options

Source

The supported C dialects of the C language used in the active project can
be selected in this box. In the "Ad" example project the Microchip C17
V2.x dialect is used.

Compiler header directories

It enables you to set the list of directories which are to be searched for the
files named using the " #i ncl ude" directive. Different directories within a
list are separated by a semicolon character. Only the listed directories are
searched for files whose names are written enclosed in brackets ("<" and
">"). The search for files whose names are written enclosed in quotation
marks ("") starts in the folder in which the source file containing the
"#include" directive resides.

The list of header directories can be assigned to a file. In that case, the
Compiler header directories box contains the file name (with absolute
or relative path in relation to the Project Root) with the @ prefix. The
directories listed in the file are separated by a semicolon or a new line (no
semicolon necessary). The prefix @ is also used in the Project file ".dcp”
to specify included files. Therefore, you should avoid using the character
@ at the beginning of the names of files and folders that are to be used in
the project.

The path of the Compiler libraries for the used CPU should be defined as
the "h" subfolder of the Microchip folder.

DAC-40-71-114
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Preinclude header file

It enables you to set the name of the file which will be included automati-
cally at the beginning of every C source module during the analysis, as if
the #i ncl ude directive containing the name of the file in question
enclosed in quotation marks ("") was present in the first line of the ana-
lyzed source code. The preinclude file is used to specify predefined mac-
ros, variable and function declarations for a particular compiler which are
not set by default in DAC analysis. The one corresponding to the Micro-
chip C17 V2.x Compiler is: "Microchip C17 V2.x.h". This file contains
declarations of Microchip C17 V2.x Compiler predefined macros.

You will need to customize this file to specify the device used in the "Ad"
example:

* Please, create the "Examples\Ad\Preinclude" subfolder of the Micro-
chip folder.

*  Copy the "Microchip C17 v2.x.h" file located in the "Preinclude
Files" subfolder of your current DAC installation folder, to the folder
you've just created.

*  Open the "Microchip C17 v2.x.h" file and remove comment from the
line containing text: "#define __ 17C756"

» Enter "Preinclude\Microchip C17 v2.x.h" in the Preinclude header
file edit box.

* Click OK.

2.6 Configuring Assembler Dialect and Header
Directories

The assembler support for Microchip C17 V2.x has not been released yet.
On the Options menu, click Assembler, and then in the Source box select
<none>.

2.7 Adding Files to the Project

In the Project Window the Explorer View replaces the Windows
Explorer and supplies you with plenty of information on directories con-
taining project files. It also gives you the possibility of adding files to the
project. All files needed to run the "Ad" example will now be added to the
project.

In the Explorer View, browse through the "Examples” subfolder of the
Microchip folder, right-click on the "Ad" subfolder and, from the shortcut

-10 -
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menu, choose Add to project. All file types configured in the previous
section Configuring File Types, are now added to the project.

Projeck B
2 o o |
[=-{E Mec ;I
D bin
{07 doc
=-{E7 Examples
ER=E!
{:l db J

L] Preinclude
{21 Examplel
{1 Examplez
{:| Example3

B0 Int =
MHame | Size: | Type | Modified
ad.bat 419 M3-DO3 Batch File 17.3.1995 6:57

W ad.c 7.32kB  CFile 31.10.2001 17:04
w Ad.dcp 2.04KB Development Assistant for C Project  13.8.2002 12:32

= ad.h 1.65KE < or C++ include file 16.12,1997 11:08
« P17cddllkr 1.88KE  LKR File 25.6,1997 10:54

w pl7cdds lkr 1.49kB  LKR File 30,10,1997 14:08
w pl7c7salkr 2.50KE  LKR File 25.9.1997 15:22

Figure 2.7 Project Window - Explorer View (Undocked mode)

Another alternative is to add each file separately by selecting each one
and adding it to the project.

2.8 Building the Database

Development Assistant for C provides the static code analysis of C and
ASM source files, and generates various data based on the results.

The analysis of the project source files and the generation of the database
are divided into two phases: the analysis of individual program modules
and the generation of data on global symbols usage. The results of the
analysis are saved in database files on the disk, allowing them to be used
in DAC later on. You can choose between the unconditional analysis of all
project files and the analysis of changed source files only, using the Build
Database and the Update Database commands from the Start menu,
respectively. The Update Database command will optionally check if the
include files used in program modules have been changed as well.

To build the database in the "Ad" example, on the Start menu click the
Build Database command. This command performs the unconditional
analysis of all project files and creates a database containing information
on the analyzed source code. The errors and warnings detected during this
operation are displayed in the Messages window as illustrated below (for
all files included in the project):

DAC-40-71-114
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Analysis for Symbols | MISRA C Compliance |

| Ling | Message

| Mote | X

ad.c
ad.c
ad.c
abH
ad.c
ad.c
ADH
ad.c
ad.c
ad.c
AacLH
ad.c

AL L LR

Warning 301
Warning 303:
Warning 303:
Warning 303:
Warning 303:
Warning 303:
Warning 301
Warning 302:
Warning 302
Warning 303:
Warning 301:
Warning 301

Device_CLK: Identifier never used

_INT: Global identifier used in only one module but defined elsewhere
delay: Global identifier used in only one module but defined elsewhere
AD_H: Global identifier used in only one module but defined elsewhere
_T0CKI: Global identifier used in only one module but defined elsewhere
_PIv: Global identifier used in only one module but defined elsewhere
FALSE: Identifier never used

lo_cnti: Global identifier defined and used in only one module

lp_cntz; Global identifier defined and used in only one module

_TMRO: Global identifier used in only one module but defined elsewhere
TRLE: Identifier never used

__STARTUP: Identifier never used

Figure 2.8 Messages Window - Analysis for Symbols tab (Undocked mode)

Once the analysis of all project files has been completed, the new data-
base file containing the information on global symbols is created. Please
refer to the DAC manual for further information on how symbols infor-
mation can be used.

-12 -
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In the DAC Project Window, select the Logical View tab and unfold

fields to get an overview of your project:

Project

EREREN

-] Ad
=3 Default (Folders)
—|-{_d Project Raat

[3 p17cads. ke
[3 pr7crsellke
¢ [=-{2 Preinclude
[ D Microchip C17 w2.x.h
E-{3 Drive C

=03 McC

E-Zdh

] P17cTSEN
=[] pt7Cach

{4 Defaulk {types)

B3 € Source Files

- [ ad.c

i{_d Assembler Source Files
-(_3 Header Files

[ adh

-3 Miscellanenus Files

[3 pr7c7sel.lke
[-{C4 Defaul {states)

Symbols I Messagesl “Werzion Infol Dependenciesl Comments | Properties [DAC]I

CACAE

| LineIName |
71 _ STARTUP
94 _INT

144 _PIV

127 _TOCKI
111 _TMRO
191 delay

K 42 Device_CLK
E 52 Ip_cntt
B 53 Ip_ent2
163 main

Figure 2.9 Project Window - Logical View (Undocked mode)
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3 Integrating the Tools
]

3.1 User-Defined Actions (UDA) Setup

To integrate the Microchip C17 V2.x tools and GNU make into DAC, on
the Option menu, click User-Defined Actions, and then click the Start
Menu Actions tab.

Now check the Use compiler template check box. By selecting this
option, you have decided on what is probably the most common manner
of using Microchip tools. The action is contained in the "Microchip C17
V2.x.tpl" file located in the "UDA Templates" subfolder of the DAC
folder. You can edit it and adjust it to your needs. RistanCASE would
appreciate your sharing additional features and ideas with us. Now click
OK.

-14 -
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User-Defined Actions [ 7] L

Start Menu Actions | Wersion Control Menu Actions I Shartcuts I Command Shell I

— Meru
Chompile File - New I [DElete | Eenamel
Compile &4 Files
ELink All Files

M ake Project i [ I

— Show output data in

U [V Use compiler
template

& WG DS Frompt. ) U DS Eutputwindow 0 Doani shov autput

— Toolbar

) Mane
= Tient I
| Eicture IMicrochip_c:ompile_file.bmp Brawze

—Action scrpt

:Save source file and et dir to project root
- #Update[ZCurFile]

#SetDil*PriRoot]

ESetwin(bIM)

;Ehec:k if the project containg neither C nor ASM source files
Zif(%CFile 2R 2(% True) %R 2(%Falze])

4 |

Ok I Cancel | Sl | Help |

= o L

Figure 3.1 User-Defined Actions - Start Menu Actions

On the View menu, point to Toolbars, and then click User-Defined
Actions. Five UDA buttons should now appear on the DAC toolbar, and
the items Compile File, Compile All Files, Link All Files, Make
Project, and Build Project on the Start menu. On the toolbar, appearing
from left to right, the UDA buttons are:

Figure 3.2 UDA toolbar (Undocked mode)

+ Compile File
» Compile All Files
+ Link All Files

* Make Project

B BD bl Bl

* Build Project

3.2 Makefile Template Setup

In order to completely define the Compile File, Compile All Files, Link
All Files, Make Project, and Build Project UDA with the gmake utility,
a project makefile must be provided. This file should have the same name

DAC-40-71-114 ©2002 RistanCASE GmbH -15-
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INFO:

You inevitably have
to make the neces-
sary customizations
of the appropriate
file for your compiler.
Follow the direc-
tions given in the
template file and
consult your com-
piler tools literature if
and when neces-

sary.

NOTE:

On every start of the
Build or Update the
Database com-
mand from the Start
menu, DAC will
automatically check
if the makefile needs
to be regenerated.

as the current project and the extension ".mak". It can be edited manually
or generated automatically.

The template files are generally used to define all the necessary macros,
commands, rules, and so on, which facilitate automatic project makefile
generation by means of the Makefile Template Macro Language instruc-
tions expansion.

Since manual editing is a very tedious and error-prone process, an exam-
ple makefile template "Microchip C17 V2.x.dmt" has been provided in the
"Makefile Generator Templates" subfolder of the DAC folder.

Another file that should be customized to reflect the properties of the tar-
get system on which a program is to be executed is the linker command
file. If the "Microchip C17 V2.x.dmt" makefile template is expanded, the
linker command file will automatically be generated along with the make-
file. The template file section responsible for the linker command line file
generation is at the end of the template and is commented.

To enable automatic makefile generation, do the following:

» Copy the file "Microchip C17 V2.x.dmt" from the "Makefile Genera-
tor Templates" subfolder of the DAC folder to the "Examples\Ad" sub-
folder of the Microchip folder.

* Customize "Microchip C17 V2.x.dmt" to your needs.

*  On the Options menu, click Makefile Generator, and then select
Generate makefile or its components.

* In the Makefile template box enter "Microchip C17 V2.x.dmt" or use
the Browse button to find it.

+ Click OK.

* On the Start menu, click Generate Makefile. The makefile for your
project will be generated automatically.

Makefile Generator Options EHE L
¥ Generate makefile or its compohents
I ak efile template
|Microchip C17 2w dmt Browse... I
Ok I Cancel I Help |
e

Figure 3.3 Makefile Generator Options

The report of the automatic project makefile generation process is dis-
played in the Messages window under the Makefile Generator tab. After

-16 -
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the project makefile has successfully been created, you can use the Link
All Files, Make Project, or Build Project UDA to generate the "Ad.out"
file.

The generated "Ad.mak" file can be opened for inspection. Please, bear in
mind that any changes made in it would be overwritten as soon as any of
the following actions from the Start menu is performed: Build Database,
Update Database or Generate Makefile. This means that if any changes
to makefiles are to be made, the make template file should be edited
instead.

DAC UDA handles compiler error reports and displays them in the Mes-
sages window under the Compiler Messages or Linker Messages tab,
depending on the UDA performed.

3.3 Using Microchip C17 V2.x Tools by Default

If you want your newly created project files to automatically inherit the
proper setup for Microchip C17 V2.x tools, you should also customize the
default DAC project file "dac.dcp”, which is located in the "Program”
subfolder of the DAC folder.

DAC-40-71-114
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Make Project 15,17
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Windows Help 4
Microchip C17 V2.x 2
Microchip C17 V2.x Tools 1
Microchip C17 V2.x.dmt 16
Microchip C17 V2.x.h 10
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New Project 2
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