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RAE V4.0

Using DAC with Keil Tools

NOTE:

This technical note
only provides infor-
mation on how to
configure DAC to
facilitate your work
with the Keil C51
V5.xx Tools, for
which the document
has primarily been
written. Using it as a
basis, DAC can eas-
ily be configured to
work with other Keil
tools. For further
information on DAC,
please refer to
"Development Assis-
tant for C" documen-
tation V4.0.

I Requirements
]

* DAC - V4.0.055 or later - (Development Assistant for C -
Ristan-CASE). The latest version, with Demo Mode license included,
can be downloaded from the following URL:
http://www.RistanCASE.com/dac/v40/dac_download.php

If you are running DAC in Demo Mode, you can easily obtain a trial
license and enjoy all the comforts of DAC for two weeks! For more
details, choose Technical Support from the Help menu.

*  GNU make V3.75 or later - (Free Software Foundation). The
gmake.exe with RistanCASE improvements can be downloaded from
the following URL:
http://www.RistanCASE.com/gnu/gnu_products.php

In the following sections, it is assumed that your Keil tools have been
installed in the "C:\KEIL" folder. In the text that follows, this folder will
be referred to as the "Keil folder." You may have to adapt the paths used
in the example provided to match your current installation paths.

Keil tools and the GNU make utility folders have to be in the system
PATH. The GNU make should be named "gmake.exe".

It is also assumed that DAC has been installed in the "C:\Program
Files\RistanCASE\Development Assistant for C" folder, which does not
have to be in the system PATH. In the text that follows this folder will be
referred to as the "DAC folder."

DAC-40-71-113
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2 Configuring DAC
]

To make the most of your Keil C51 V5.xx tools with DAC, these are the
steps to follow:

* Creating a New Project
e Configuring Working Directories

e Configuring File Types
o Configuring Analysis for Symbols

e Configuring Compiler Dialect and Header Directories

e Configuring Assembler Dialect and Header Directories

* Adding Files to the Project

* Building the Database

e Integrating the Tools
As you progress through this technical note, you will be led through the
process of creating a new DAC project named "Sieve." The "Sieve"
example project can be found on RistanCASE's CD-ROM in the
"DAC\Technical Notes\Keil" folder, or downloaded from RistanCASE's

web site:
http://www.RistanCASE.com/dac/v40/specificsupport/keil.php

Tools supported by DAC - V4.0.055 or later

Supported compilers Supported assemblers

Keil C166 (until V4.0) Keil A166 V3.xx
Keil C166 V4.xx
Keil C251 (until V2.0)
Keil C251 V2.xx

-2- ©2002 RistanCASE GmbH DAC-40-71-113
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Tools supported by DAC - V4.0.055 or later (Continued)

Supported compilers Supported assemblers

Keil C251 V3.xx Keil A251 V3.xx
Keil C51 (until V5.0)
Keil C51 V5.xx

Keil C51 V6.xx Keil A51 V6.xx

2.1 Creating a New Project

Start DAC and choose New Project from the Project menu. Browse
through the "C5I\EXAMPLES\SIEVE" subfolder of the Keil folder and
enter the project file name "Sieve". A project file will be created. The
standard project file extension is ".dcp"”, so the created file will be named

"Sieve.dcp".

Mew
Savein: | (3 SIEVE =l =
File name: ISieve Save I
Save as type: IProiect file [*.dcp] j Cancel |

Figure 2.1 Creating a new project

2.2 Configuring Working Directories

On the Options menu, click Project to show the Project Options dialog
box. Use this dialog box to set project directories:

DAC-40-71-113 ©2002 RistanCASE GmbH -3-
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Project Options L
Directories | File Types I Miscellaneousl

Praject Root directary
I. Browse... |
Fieferential Project Root directory
| Browse... |
Header Directoriez
I Browse... |
Databaze directary
|_dh Browse. .. |
User Help file
IE:\KEIL\EE'I SHLPYCSTlib. chm Browse... |
™ Automatically add new project paths to Header directories.

o]

Cancel I Help I

Figure 2.2 Configuring working directories

Project Root directory

The full path i1s expected in the Project Root directory text box or, as a
special value, a single period character, which stands for "the directory
where the project file resides." The names of all files belonging to the
project are considered relative to the Project Root directory if the full file
path is not given. In our example, keep the single period character for the
Project Root directory.

Referential Project Root directory

If not empty, it specifies an alternative path for searching for files that
DAC fails to find in the original project path. DAC will attempt to find
files with the referential extension in the Project Root directory prior to
searching the referential Project Root directory. The specified path may
either be full or relative to the Project Root, and it may not specify a sub-
folder in the Project Root directory tree. In this example it should be left
empty.

Header Directories

You should specify paths to all header directories used in the project. The
paths are separated by a semicolon.

Database directory

It allows the Symbols and Software Metrics database files folder to be set.
The path in question can be absolute or relative to the Project Root direc-
tory. If the Database directory is left unspecified, the Symbols and Soft-
ware Metrics database files are created in the Project Root directory along
with source and other files. It is recommended that you should specify the
Database directory, to keep these files from mixing. Enter " _db" in the
box.

©2002 RistanCASE GmbH DAC-40-71-113
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User Help file

It enables you to set the User Help file, for example, the Compiler Help
file. The shortcut key for the User Help file can be set in the Keyboard
definition file (default CTRL + SHIFT + F1). Browse through the "Hip"
subfolder of the Keil folder and select the "C51/ib.chm" help file. This
will give you an entry point for Keil C51 V5.xx help.

2.3 Configuring File Types

On the Options menu, click Project and select the File Types tab. Here
you can set file extensions for the basic project file types. A file type
extension list consists of up to 10 file extensions separated by a white

space or the "." character. To ensure maximally efficient use of Keil C51
V5.xx tools, fill in the boxes as shown in the following picture:

Project Options L
Directories  File Types | Miscellaneousl
— Referential
L Source file Original ~ Ref.
B T
Azzembler 5 ource file
|.551 Jine I I
Header file
|h | [
Document file
|.doc.rtf I I
Text file
I.txt.lst. ma1.dep.tpl.dmt.mak. cml I I

ak. I Cancel I Help I

Figure 2.3 Configuring File Types

C Source file

Files with one of the extensions listed in this box will be considered C
source files. Header file extensions should not be defined within this field.
Enter ".c" in the box.

Assembler Source file

Files with one of the extensions listed in this box will be considered
included Assembler files. Module file extensions should not be defined
within this field. Enter ".a51.inc" in the box.

Header file

Files with one of the extensions listed in this box will be considered
included C header files. Module file extensions should not be defined
within this field. Enter ".h" in the box.

DAC-40-71-113
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Document file

Files with one of the extensions listed in this box will be considered docu-
ment files. Enter ".doc.rtf" in the box.

Text file

Files with one of the extensions listed in this box will be considered edit-
able (text) files. If files without extensions are to be considered editable,
the list ends with a period ".". Enter ".txt.Ist. m51.dcp.tpl.dmt.mak.cml" in
the box.

Referential pairs

Fields for entering alternative (referential) extensions are located in this
area. The original extension is entered in the Original column, while the
alternative extension is entered in the Referential column. Up to five orig-
inal / alternative pairs can be set. If opening the file with the original
extension fails, DAC will attempt to find and open the file with the identi-
cal name and the alternative extension.

2.4 Configuring Analysis for Symbols

For this example you may need to configure Analysis for Symbols
Options from General and C Source sections.

©2002 RistanCASE GmbH DAC-40-71-113
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2.4.1 General

On the Options menu, click Analysis for Symbols, and then click the
General tab to show the following dialog box:

Analysis for Symbols Options HE L

Gereral | C Sourcel W'arningsl MISRA C Eompliancel Syrbol Mame Eheckingl

—Wwarning —Header
" Digabled W Check headers on update
" Enabled W Use default search
" Dizabled for all headers ™ Use search paths
' Disabled for standard library headers ™ Use ¥axMAMS dives
¥ Show unresolved externals - Stop After
W Show unused symbols I_D Errars
IV Globals/statics used in one
module/function I_D Wanings

Environment substitute:

=

Ok I Cancel | Al I Help |

Figure 2.4 General Analysis for Symbols Options

Environment substitutes

Environment variables defined in Windows can be made a part of various
path specifications in DAC by enclosing the variable identifier in "%"
characters. Apart from variables defined in the Windows environment, it
is possible, in Environment substitutes, also to define "DAC environ-
ment variables" in the form of:

env_var=env_string

If the %env_var %construct is found in DAC paths (project root directory,
database directory, include path, %Env(env_var), ...) %env_var %will be
replaced with an env_stri ng.

These substitutions are also necessary if the environment variables of
your development environment have been set only in the DOS window in
which you build project binaries. As the variables are not known at Win-
dows level, if you intend to use them, you will have to define them in
DAC, in Environment substitutes.

For a detailed explanation of other options in the General tab please con-
sult DAC help.

DAC-40-71-113
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2.4.2 C Source

On the Options menu, click Analysis for Symbols, and then click the C
Source tab to show the following dialog box:

Analysis for Symbols Options HE L

General C Source IWarningsI MISRA C Eompliancel Syrbol Mame Eheckingl

‘ Max identifier length I N [™ Special table processing ‘

Preprocessor
Defines/Contral file

I Browse... I

[~ Mested comments W C++ comments [ Traditional [ lgnore #line

Ok I Cancel | Al I Help

Figure 2.5 C Source Analysis for Symbols Options

Maximum identifier length

This is the number of significant characters in the identifiers. The remain-
ing characters are ignored. The default value is 31.

Special table processing

It determines the treatment of arrays of pointers to functions in the analy-
sis. If this option is selected, such variables are treated as functions, other-
wise, they are treated in the usual way (default).

Defines / Control file

It determines the list of macro definitions to be set at the beginning of the
module preprocessing. This box may contain the control file name (with
absolute or relative path in relation to the project root) with the prefix @.
The prefix @ is also used in the Project file ".dcp” to specify included
files. Therefore, you should avoid using the character @ at the beginning
of the names of files and folders that are to be used in the project. Control
file lines beginning with -i or -I subsequently contain the list of directories
for searching for #i ncl ude files, separated by a semicolon. Control file
lines beginning with -d or -D subsequently contain the list of macro defi-
nitions, as described in the previous paragraph. The remaining control file
lines are ignored.

©2002 RistanCASE GmbH DAC-40-71-113



RAE V4.0

Using DAC with Keil Tools

Nested comments

It allows proper recognition of nested C style comments, for example / *
[* o0 %],

C+ + comments

It determines whether C++ comments (beginning with "//") are to be rec-
ognized while analyzing the source code.

Traditional

It determines if the pre-ANSI preprocessor is to be used. For the tradi-
tional preprocessor, a comment is equivalent to nothing, while for the
ANSI preprocessor it is a white space. The traditional preprocessor does
not delete comments within the #def i ne directive, it does not recognize
"#" and "##" operators, and requires an initial "#" in a directive at the
very beginning of the line. It allows specification f oo() if a macro f oo
takes a single argument, and permits a macro to be expanded recursively.

Ignore #line

It determines that the #I i ne preprocessor directive be ignored.

2.5 Configuring Compiler Dialect and Header
Directories

An additional path configuration must be performed to specify the loca-
tion of the Keil C51 V5.xx compiler library header file (needed for DAC
symbol analysis). On the Options menu, click Compiler to show the
Options: Compiler dialog box. This dialog box contains options which
enable you to set C source code analysis parameters:

DAC-40-71-113
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Options: Compiler HE L

Compiler |

—Source

|Keil C51 V. =l

LCompiler header directories

|C: WREILAERTMMG Browse... |
Freinclude header file
|Keil C51 5w Browse... |

ak. I Cancel Seprli Help

Figure 2.6 Compiler Options

Source

The supported C dialects of the C language used in the active project can
be selected in this box. In the "Sieve" example project the Keil C51 V5.xx
dialect is used.

Compiler header directories

It enables you to set the list of directories which are to be searched for the
files named using the " #i ncl ude" directive. Different directories within a
list are separated by a semicolon character. Only listed directories are
searched for files whose names are written enclosed in brackets ("<" and
">"), The search for files whose names are written enclosed in quotation
marks ("") starts in the folder in which the source file containing the
"#include" directive resides.

The list of header directories can be assigned to a file. In that case, the
Compiler header directories box contains the file name (with absolute
or relative path in relation to the Project Root) with the @ prefix. The
directories listed in the file are separated by a semicolon or a new line (no
semicolon necessary). The prefix @ is also used in the Project file ".dcp”
to specify included files. Therefore, you should avoid using the character
@ at the beginning of the names of files and folders that are to be used in
the project.

The path of the Compiler libraries for the used CPU should be defined as
the "C51\INC" subfolder the Keil folder.

-10 -
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Preinclude header file

It enables you to set the name of the file which will be included automati-
cally at the beginning of every C source module during the analysis, as if
the #i ncl ude directive containing the name of the file in question
enclosed in quotation marks ("") was present in the first line of the ana-
lyzed source code. The preinclude file is used to specify predefined mac-
ros, variable and function declarations for a particular compiler which are
not set by default in DAC analysis. The one corresponding to the Keil
C51 V5.xx compiler has been selected here: "Keil C51 V5.xx.h". This file
contains declarations of Keil C51 Compiler predefined macros. It is
located in the "Preinclude Files" subfolder of the DAC folder. To adapt
this file to your needs, on the File menu, point to Configuration Files and
click Compiler Preinclude File.

2.6 Configuring Assembler Dialect and Header
Directories

On the Options menu, click Assembler to show the Options: Assembler
dialog box. This dialog box contains options which enable you to set
assembler source code analysis parameters:

Options: Azsembler k
Azzembler |
—Source
|Keil A5 V6.x =l
Azzembler header files
|E: WKEILVCRThWAS M Browsze... |
Preinclude header file
| Browse... |
- Dialect specific option:
Define symbol values
|

0k I Cancel Ll Help

Figure 2.7 Assembler Options

Source

The supported assembler language used in the current project. It is possi-
ble to select a particular dialect, or the value <none> which means that
parts of the C code containing inline assembler code will be ignored
(information on symbols will not be retrieved, but no syntax errors will

DAC-40-71-113
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occur either). In the "Sieve" example project, the Keil A51 V6.xx assem-
bler is used.

Assembler header files

It determines a list of directories which are to be searched for the files
named within the | NCLUDE directive. Directories are separated by a semi-
colon. Enter "C:\KEIL\C51\ASM" in the box.

Preinclude header file

If a file is specified in this edit box (typed in or selected using the Browse
button), it will be included in each assembler file prior to commencing
assembler analysis. This is identical to entering the | NCLUDE directive in
each assembler file.

Define symbol values

In this edit box, you can define symbols prior to commencing analysis.
The content should have the format name_1 = value_1; name_2 =
value_2; ... In this way the symbol name _i is defined and has the value
value i. A predefined symbol name may contain letters, digits, and
underscore characters, and may not begin with a digit. The content fol-
lowing the "=" character may contain any characters except the ";" char-
acter. Predefined symbols are treated as macros and are substituted
directly in the text, with multiple substitution of such symbols not sup-
ported. This means that if the content of the Define symbol values edit
box is name 1 =name_ 2; name_2 = value 2, and the analyzed text con-
tains a line which reads name_1, then the resulting line will read name_2.

2.7 Adding Files to the Project

In the Project Window the Explorer View replaces the Windows
Explorer and supplies you with plenty of information on directories con-
taining project files. It also gives you the possibility of adding files to the
project. All files needed to run the "Sieve" example will now be added to
the project.

In the Explorer View, browse through the "C5/\EXAMPLES" subfolder

of the Keil folder, and select the "Sieve” subfolder. Right-click and choose
Add to project. All file types configured in the previous section Config-
uring File Types, are now added to the project:

-12 -
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3 oo |
E-{E] Examples ;l
-] A1
-{{] Badcode
-] Bank_EX1
[-{Z] Czample
-] Des J
B2 Dy
-] Hella
-] Meazure
E1-E3 Sieve
L3 _db
-7 Traffic
-] Whets =
CAKEILACRINERAMPLESNSIEVES
Mame | Sizel Type | Modified |
w Abstracttst 1.37KE  Test Document 19411797 04:20 &M
v Sieve.c 1.95KB  CFile 23/08/99 08:29 AM
+ Sievedocp  1.69KB  Development dssistant for C Project  12/04/02 18:58 PM
Sieve.opt  1.62KB OPT File 23/03/01 12:27 PM
Sieveve  3.26KB  UVZFile 23/03/01 12:27 PM

Figure 2.8 Project Window - Explorer View (Undocked mode)

Another alternative is to add each file separately by selecting each one
and adding it to the project.

2.8 Building the Database

Development Assistant for C provides the static code analysis of C and
ASM source files, and generates various data based on the results.

The analysis of the project source files and the generation of the database
are divided into two phases: the analysis of individual program modules
and the generation of data on global symbols usage. The results of the
analysis are saved in database files on the disk, allowing them to be used
in DAC later on. You can choose between the unconditional analysis of all
project files and the analysis of changed source files only, using the Build
Database and the Update Database commands from the Start menu,
respectively. The Update Database command will optionally check if the
include files used in program modules have been changed as well.

To build the database in the "Sieve" example, on the Start menu click the
Build Database command. This command performs the unconditional
analysis of all project files and creates a database containing information
on the analyzed source code. The errors and warnings detected during this
operation are displayed in the Messages window as illustrated (for the
"Sieve.c" sample file):

DAC-40-71-113 ©2002 RistanCASE GmbH -13 -
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Messages H

Analysis for Symbols | MISFA C Compiance |

I File I LineI Meszage

|£

* Tievec 137 Waming 302 lags, Global identif

defined and yzed in only one module

Figure 2.9 Messages Window - Analysis for Symbols tab (Undocked mode)

Once the analysis of all project files has been completed, the new data-
base file containing the information on global symbols is created. Please
refer to the DAC manual for further information on how symbols infor-

mation can be used.

In the DAC Project Window, select the Logical View tab and unfold

fields to get an overview of your project:

3 o O |
El-{] Sieve

E|C2 Default [folders]
EC] Project Foot
- [q Abstract bt
..... [ Sieve.c
P [ Sievedep
B3 DiiveC

B3 KELL

B3 Program Files
B3 RistanCASE

E+{_4 Preinclude Files

[-]C] Default [types]
|_-—_|D C Source Files

{Z2 Assembler Source Files
-{_2 Header Files
-{Z2 Document Files
E-{C3 Miscellaneous Files
[ dbstract tat
[ Sieve.dcp
E-{Z3 Default [states)
[F-{C4 Wiitable
-{_2 Fead Only
-{Z2 Changed
F-{Z4 Mot Changed

EID Development Azzistant for C

CAREILACETSEXAMPLESHSIEVESSIEVE.C

CACATE AT

Symbols | Messagesl Wersion Infol Dependenciesl Commentz | Properties [DALC)

| Line | Marne I

19 count
10 FALSE
13 flags
18 i

19 iter

18 k

17 main

19 prime
11 SIZE
9 TRUE

[=]=]<[ 1] <] =]-]=]-]

Figure 2.10 Project Window - Logical View (Undocked Mode)
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3 Integrating the Tools
]

3.1 User-Defined Actions (UDA) Setup

To integrate Keil C51 V5.xx tools and GNU make into DAC, on the
Option menu, click User-Defined Actions, and then click the Start
Menu Actions tab.

Now check the Use compiler template check box. By selecting this
option, you have decided on what is probably the most common manner
of using Keil tools. The action is contained in the "Keil C51 V5.xx.tpl" file
located in the "UDA Templates" subfolder of the DAC folder. You can edit
it and adjust it to your needs. RistanCASE would appreciate your sharing
additional features and ideas with us. Now click OK.

DAC-40-71-113
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Usger-Defined Actions

Start Menu Actions | Wersion Control Menu Actions I Shortcuts I Command Shell I

— Menu

Chompile File
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Figure 3.1 User-Defined Actions - Start Menu Actions

On the View menu, point to Toolbars, and then click User-Defined
Actions. Five UDA buttons should now appear on the DAC toolbar, and
the items Compile File, Compile All Files, Link All Files, Make
Project, and Build Project on the Start menu. On the toolbar, appearing

from left to right, the UDA buttons are:

L S e

Figure 3.2 UDA toolbar (undocked mode)

Compile File
* Compile All Files
« Link All Files

* Make Project

» Build Project

3.2 Makefile Template Setup

In order to completely define the Compile File, Compile All Files, Link
All Files, Make Project, and Build Project UDA with the gmake utility,
a project makefile must be provided. This file should have the same name
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INFO:

You inevitably have
to make the neces-
sary customizations
of the appropriate
file for their compiler.
Follow the direc-
tions given in the
template file and
consult your com-
piler tools literature if
and when neces-

sary.

NOTE:

On every start of the
Build or Update the
Database com-
mand from the Start
menu, DAC will
automatically check
if the makefile needs
to be regenerated.

as the current project and the extension ".mak". It can be edited manually
or generated automatically.

The template files are generally used to define all the necessary macros,
commands, rules, and so on, which facilitate automatic project makefile
generation by means of the Makefile Template Macro Language instruc-
tions expansion.

Since manual editing is a very tedious and error-prone process, an exam-
ple makefile template "Keil C51 V5.xx.dmt" has been provided in the
"Makefile Generator Templates" subfolder of the DAC folder.

Another file that should be customized to reflect the properties of a target
system on which a program is to be executed is the linker command file.
If the "Keil C51 V5.xx.dmt" makefile template is expanded, the linker
command file will automatically be generated along with the makefile.
The template file section responsible for the linker command line file gen-
eration is at the end of the template and is marked.

To enable automatic makefile generation, do the following:

»  Copy the file "Keil C51 V5.xx.dmt" from the "Makefile Generator
Templates" subfolder of the DAC folder to the "C51\EXAM-
PLES\SIEVE" subfolder of the Keil folder.

* Customize "Keil C51 V5.xx.dmt" to your needs.

*  On the Options menu, click Makefile Generator, and then select
Generate makefile or its components.

* In the Makefile template box enter "Keil C51 V5.xx.dmt" or use the
Browse button to find it.

* Click OK.

* On the Start menu, click Generate Makefile. The makefile for your
project will be generated automatically.

Makefile Generator Options

1|

rd Generate makefile or its components

b akefile template
|Keil C51 5. x.dmt

Browse... |

LCancel | Help |

Figure 3.3 Makefile Generator Options

The report of the automatic project makefile generation process is dis-
played in the Messages window under the Makefile Generator tab. After

DAC-40-71-113
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the project makefile has successfully been created, you can use the Link
All Files, Make Project, or Build Project UDA to generate the
"Sieve.abs" and "Sieve.hex" files.

The generated "Sieve.mak" file can be opened for inspection. Please, bear
in mind that any changes made in it would be overwritten as soon as any
of the following actions from the Start menu is performed: Build Data-
base, Update Database or Generate Makefile. This means that if any
changes to makefiles are to be made, the make template file should be
edited instead.

DAC UDA handles compiler error reports and displays them in the Mes-
sages window under the Compiler Messages or Linker Messages tab,
depending on the UDA performed.

3.3 Using Keil Tools by Default

If you want your newly created project files to automatically inherit the
proper setup for Keil C51 V5.xx tools, you should also customize the
default DAC project file "dac.dcp”, which is located in the "Program”
subfolder of the DAC folder.
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