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Using DAC with Diab Data Tools

NOTE:

This technical note
only provides infor-
mation on how to
configure DAC to
facilitate your work
with the Diab Data
PowerPC V4.x
Tools, for which the
document has pri-
marily been written.
Using it as a basis,
DAC can easily be
configured to work
with other Diab Data
tools. For further
information on DAC,
please refer to
"Development Assis-
tant for C" documen-
tation V4.0.

I Requirements
]

* DAC - V4.0.055 or later - (Development Assistant for C -
RistanCASE). The latest version, with Demo Mode license included,
can be downloaded from the following URL:
http://www.RistanCASE.com/dac/v40/dac_download.php

If you are running DAC in Demo Mode, you can easily obtain a trial
license and enjoy all the comforts of DAC for two weeks! For more
details, choose Technical Support from the Help menu.

* GNU make V3.75 or later - (Free Software Foundation). The
gmake.exe with RistanCASE improvements can be downloaded from
the following URL:
http://www.RistanCASE.com/gnu/gnu_products.php

In the following sections, it is assumed that your Diab Data PowerPC
V4 .x tools have been installed in the "C:\Diab\4.4b" folder. In the text
that follows, this folder will be referred to as the "Diab Data folder." You
may have to adapt the paths used in the example provided to match your
current installation paths.

The "win32\BIN" subfolder of the Diab Data folder and the GNU make
utility folders have to be in the system PATH. The GNU make should be
named "gmake.exe".

It is also assumed that DAC has been installed in the "C:\Program
Files\RistanCASE\Development Assistant for C" folder, which does not
have to be in the system PATH. In the text that follows this folder will be
referred to as the "DAC folder."

DAC-40-71-119
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Using DAC with Diab Data Tools

2 Configuring DAC
]

To make the most of your Diab Data PowerPC V4.x tools with DAC,
these are the steps to follow:

* Creating a New Project

e Configuring Working Directories

e Configuring Analysis for Symbols

e Configuring Compiler Dialect and Header Directories
¢ Configuring Assembler Dialect and Header Directories
* Adding Files to the Project

* Building the Database

e Integrating the Tools

As you progress through this technical note, you will be led through the
process of creating a new DAC project named "Bubble." The "Bubble"
example project can be found on RistanCASE's CD-ROM in the
"DAC\Technical Notes\Diab Data" folder, or downloaded from
RistanCASE's web site: http://www.RistanCASE.com/dac/v40/specific-
support/diab_data.php

Supported tools by DAC - V4.0.055 or later

Supported compilers

Diab Data 68K/CPU32 V4 .x
Diab Data PowerPC V4.x

©2002 RistanCASE GmbH DAC-40-71-119
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Using DAC with Diab Data Tools

2.1 Creating a New Project

Start DAC and choose New Project from the Project menu. Browse
through the "example\powerpc"” subfolder of the Diab Data folder and
enter the project file name "Bubble". A project file will be created. The
standard project file extension is ".dcp”, so the created file will be named
"Bubble.dcp".

New [7] L
Save in: I {3 powerpe j - % E3-
File: name: |Bubble Gave I
Sawve as ype: | Project fils dcp) =l Earnea |

Figure 2.1 Creating a new project

2.2 Configuring Working Directories

On the Options menu, click Project to open the Project Options dialog
box. Use this dialog box to set project directories:

Project Options k

Directaries I File Typesl Miscellansous I

Project Boot directary
I. Browse...

Referential Project Root directony
| Browse...

Header Directories
I Browse...

Databaze directory
|_db Browse...

User Help file
I Browse...

PEEEE

™ Automatically add new project paths to Header directories.

] I Cancel | Help |

Figure 2.2 Configuring working directories

Project Root directory

The full path is expected in the Project Root directory text box or, as a
special value, a single period character, which stands for "the directory
where the project file resides." The names of all files belonging to the
project are considered relative to the Project Root directory if the full file

DAC-40-71-119

©2002 RistanCASE GmbH -3-



Using DAC with Diab Data Tools

path is not given. In our example, keep the single period character for the
Project Root directory.

Referential Project Root directory

If not empty, it specifies an alternative path for searching for files that
DAC fails to find in the original project path. DAC will attempt to find
files with the referential extension in the Project Root directory prior to
searching the referential Project Root directory. The specified path may
either be full or relative to the Project Root, and it may not specify a sub-
folder in the Project Root directory tree. In this example it should be left
empty.

Header Directories

You should specify paths to all header directories used in the project. The
paths are separated by a semicolon.

Database directory

It allows the Symbols and Software Metrics database files folder to be set.
The path in question can be absolute or relative to the Project Root direc-
tory. If the Database directory is left unspecified, the Symbols and Soft-
ware Metrics database files are created in the Project Root directory along
with source and other files. It is recommended that you should specify the
Database directory, to keep these files from mixing. Enter " _db" in the
box.

User Help file

It enables you to set the User Help file, for example, the Compiler Help
file. The shortcut key for the User Help file can be set in the Keyboard
definition file (default CTRL + SHIFT + F1).

2.3 Configuring File Types

On the Options menu, click Project and select the File Types tab. Here
you can set file extensions for the basic project file types. A file type
extension list consists of up to 10 file extensions separated by a white

space or the "." character. To ensure maximally efficient use of Diab Data
PowerPC V4 .x tools, fill in the boxes as shown in the following picture:

©2002 RistanCASE GmbH DAC-40-71-119
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Project Options ﬂ k
Directories  File Types I Miscellansous I
— Referential
L Source file Original ~ Fef.
[c .
Agszembler Source file
I.s. inc I I
Header file
|-h [ [
Document file
I.doc. iitf I I
Text file
I.txt.dc:p.dmt.mak.dld.erc.era.erl.mpc.tpl I I

] I Cancel | Help |

Figure 2.3 Configuring File Types

C Source file

Files with one of the extensions listed in this box will be considered C
source files. Header file extensions should not be defined within this field.
Enter ".c" in the box.

Assembler Source file

Files with one of the extensions listed in this box will be considered
included Assembler files. Module file extensions should not be defined
within this field. Enter ".s.inc" in the box.

Header file

Files with one of the extensions listed in this box will be considered
included C header files. Module file extensions should not be defined
within this field. Enter ".h" in the box.

Document file

Files with one of the extensions listed in this box will be considered docu-
ment files. Enter ".doc.rtf" in the box.

Text file

Files with one of the extensions listed in this box will be considered edit-
able (text) files. If files without extensions are to be considered editable,
the list ends with a period ".". Enter ".txt.dcp.dmt.mak.dld.erc.era.erl.mpc
.tpl" in the box.

Referential pairs

Fields for entering alternative (referential) extensions are located in this
area. The original extension is entered in the Original column, while the
alternative extension is entered in the Referential column. Up to five orig-

DAC-40-71-119
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Using DAC with Diab Data Tools

inal / alternative pairs can be set. If opening the file with the original
extension fails, DAC will attempt to find and open the file with the identi-
cal name and the alternative extension.

2.4 Configuring Analysis for Symbols

For this example you may need to configure Analysis for Symbols
Options from General and C Source sections.

2.4.1 General

On the Options menu, click Analysis for Symbols, and then click the
General tab to open the following dialog box:

Analysis for Symbols Options L

General | C Source I warnings I MISRA C Compliance I Symbol Mame Checking I

—'Warning —Header
" Dizabled ¥ Check headers on update
" Enabled IV Use default ssarch
" Dizabled for all headers ™ Use zearch paths
¢ Digabled for standard library headers [ Use VARAMS dives
W Show unresolved externals - Stop After———————————
¥ Show unuzed spmbils I_D Errors
W Globals/statics uzed in one
module/function I_D wamirigs

Enviranment substitutes

[
-

ok I Cancel | Spply | Help |

Figure 2.4 General Analysis for Symbols Options

Environment substitutes

Environment variables defined in Windows can be made a part of various
path specifications in DAC by enclosing the variable identifier in "%"
characters. Apart from variables defined in the Windows environment, it
is possible, in Environment substitutes, also to define "DAC environ-
ment variables" in the form of:

env_var=env_string

If the %env_var %construct is found in DAC paths (project root directory,
database directory, include path, %Env(env_var), ...) %env_var %will be
replaced with an env_stri ng.

©2002 RistanCASE GmbH DAC-40-71-119



Using DAC with Diab Data Tools

These substitutions are also necessary if the environment variables of
your development environment have been set only in the DOS window in
which you build project binaries. As the variables are not known at Win-
dows level, if you intend to use them, you will have to define them in
DAC, in Environment substitutes.

For a detailed explanation of other options in the General tab please con-
sult DAC help.

2.4.2 C Source

On the Options menu, click Analysis for Symbols, and then click the C
Source tab to show the following dialog box:

Analysis for Symbols Options 17} L

General C Source | W arnings | MISRA C Compliance | Sumbal Marme Checking I

‘ Max identifier length I Kl [ Special table processing ‘

Freproceszor
Defines/Control file

I Browse... |

I Mested comments W C++ comment: [ Tradiional [ lgnare #line

Ok I Cancel | ol | Help

Figure 2.5 C Source Analysis for Symbols Options

Maximum identifier length

This is the number of significant characters in the identifiers. The remain-
ing characters are ignored. The default value is 31.

Special table processing

It determines the treatment of arrays of pointers to functions in the analy-
sis. If this option is selected, such variables are treated as functions, other-
wise, they are treated in the usual way (default).

Defines / Control file

It determines the list of macro definitions to be set at the beginning of the
module preprocessing. This box may contain the control file name (with
absolute or relative path in relation to the project root) with the prefix @.

DAC-40-71-119
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Using DAC with Diab Data Tools

The prefix @ is also used in the Project file ".dcp"” to specify included
files. Therefore, you should avoid using the character @ at the beginning
of the names of files and folders that are to be used in the project. Control
file lines beginning with -i or -1 subsequently contain the list of directories
for searching for #i ncl ude files, separated by a semicolon. Control file
lines beginning with -d or -D subsequently contain the list of macro defi-
nitions, as described in the previous paragraph. The remaining control file
lines are ignored.

Nested comments

It allows proper recognition of nested C style comments, for example / *
[* o0 %

C++ comments

It determines if C++ comments (beginning with "//") are to be recognized
while analyzing the source code.

Traditional

It determines if the pre-ANSI preprocessor is to be used. For the tradi-
tional preprocessor, a comment is equivalent to nothing, while for the
ANSI preprocessor it is a white space. The traditional preprocessor does
not delete comments within the #def i ne directive, it does not recognize
"#" and "##" operators, and requires an initial "#" in a directive at the
very beginning of the line. It allows specification f oo() if a macro f oo
takes a single argument, and permits a macro to be expanded recursively.

Ignore #line

It determines that the #| i ne preprocessor directive be ignored.

2.5 Configuring Compiler Dialect and Header
Directories

An additional path configuration must be performed to specify the loca-
tion of the Diab Data PowerPC V4.x C compiler library header file
(needed for DAC symbol analysis). On the Options menu, click Com-
piler to open the Compiler Options dialog box. This dialog box contains
options which enable you to set C source code analysis parameters:

©2002 RistanCASE GmbH DAC-40-71-119
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compieroppions g

Compiler |

— Source
| Dish Data PoweiPC V.5 = Heb |
Compiler header directories
|E:\Diab'\4. 4bhinclude Browse... |
Preinclude header file
|Diab Data PowerPC Yé.xh Browse... |

Ok I Cancel ) [ Help

Figure 2.6 Compiler Options

Source

The supported C dialects of the C language used in the active project can
be selected in this box. In the "Bubble" example project the Diab Data
PowerPC V4.x C dialect is used.

Compiler header directories

It enables you to set the list of directories which are to be searched for the
files named using the " #i ncl ude" directive. Different directories within a
list are separated by a semicolon character. Only listed directories are
searched for files whose names are written enclosed in brackets ("<" and
">"). The search for files whose names are written enclosed in quotation
marks ("") starts in the folder in which the source file containing the
"#include" directive resides.

The list of header directories can be assigned to a file. In that case, the
Compiler header directories box contains the file name (with absolute
or relative path in relation to the Project Root) with the @ prefix. The
directories listed in the file are separated by a semicolon or a new line (no
semicolon necessary). The prefix @ is also used in the Project file ".dcp”
to specify included files. Therefore, you should avoid using the character
@ at the beginning of the names of files and folders that are to be used in
the project.

The path of the Compiler libraries for the used CPU should be defined as
the "include" subfolder of the Diab Data folder.

DAC-40-71-119

©2002 RistanCASE GmbH -9-



Using DAC with Diab Data Tools

Preinclude header file

It enables you to set the name of the file which will be included automati-
cally at the beginning of every C source module during the analysis, as if
the #i ncl ude directive containing the name of the file in question
enclosed in quotation marks ("") was present in the first line of the ana-
lyzed source code. The preinclude file is used to specify predefined mac-
ros, variable and function declarations for a particular compiler which are
not set by default in DAC analysis. The one corresponding to the Diab
Data PowerPC V4.x C Compiler is: "Diab Data PowerPC V4.x.h". This
file contains declarations of Diab Data PowerPC V4.x C Compiler pre-
defined macros. To adapt this file to your needs, on the File menu, point
to Configuration Files and click Compiler Preinclude File.

2.6 Configuring Assembler Dialect and Header
Directories

Assembler support for Diab Data PowerPC V4.x has not been released
yet. On the Options menu, click Assembler, and then in the Source box
select <none>.

2.7 Adding Files to the Project

In the Project Window the Explorer View replaces the Windows
Explorer and supplies you with plenty of information on directories con-
taining project files. It also gives you the possibility of adding files to the
project. All files needed to run the "Bubble" example will now be added
to the project.

In the Explorer View, browse through "example"” subfolder of the Diab
Data folder, right-click on the "powerpc"” subfolder and, from the shortcut
menu, choose Add to project. All file types configured in the previous
section Configuring File Types, are now added to the project. Remove the
files not belonging to the project.

Projeck B
2 |o o |
(] carf =
-] dmaks
E-{E example
Ea powerpc
3] _cb
-] include =l

| Modified
3.10,2000 7:20

Mame | Size | Tvpe
< bubble.c 2.41KE CFile

« Bubble.dcp 1.70KE  Development Assistant for C Project  6.6,2002 16:34

w bubble,did 7.26kB  DLD File

wo Crtd.s 3.08KB 5 File
rakefile 759 File

L SWAD.S 967 5 File

28,5,1999 20:57
18.5.1999 23:56
37,1999 3:06

1.10.1995 16:10

Figure 2.7 Project Window - Explorer View (Undocked mode)
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DAE V4.0 Using DAC with Diab Data Tools

Another alternative is to add each file separately by selecting each one
and adding it to the project.

2.8 Building the Database

Development Assistant for C provides the static code analysis of C and
ASM source files, and generates various data based on the results.

The analysis of the project source files and the generation of the database
are divided into two phases: the analysis of individual program modules
and the generation of data on global symbols usage. The results of the
analysis are saved in database files on the disk, allowing them to be used
in DAC later on. You can choose between the unconditional analysis of all
project files and the analysis of changed source files only, using the Build
Database and the Update Database commands from the Start menu,
respectively. The Update Database command will optionally check if the
include files used in program modules have been changed as well.

To build the database in the "Bubble" example, on the Start menu click
the Build Database command. This command performs the uncondi-
tional analysis of all project files and creates a database containing infor-
mation on the analyzed source code. The errors and warnings detected
during this operation are displayed in the Messages window as illustrated
(for the "Bubble.c" sample file):

Analysis for Symbols | MISRA C Compliance |
I File: | Linel Message | [oke |&
#+ bubble.c 32 Warning 301: address_o: Identifier never used
4+ bubble.c &4 | Warning 309: exit: Function call without declaration
#+ bubble.c 24 | Warning 302; input_count: Global identifier defined and used in only one module
+ bubble.c 32 | Warning 302: get_short: Global identifier defined and used in only one module
+ bubble.c 16 | Warning 302; swap: Global identifier defined and used in only one module
+ bubble.c 16 | Warning 305; swap: Missing global definition
#+ hubble.c 28 | Warning 302: array: Global identifier defined and used in only one madule
[ ] Warning 303: exit: Global identifier used in only one madule but defined elsewhere
[ ] Warning 305; exit: Missing global definition

Figure 2.8 Messages Window - Analysis for Symbols tab (Undocked mode)

Once the analysis of all project files has been completed, the new data-
base file containing the information on global symbols is created. Please
refer to the DAC manual for further information on how symbols infor-
mation can be used.

DAC-40-71-119 ©2002 RistanCASE GmbH -11 -
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In the DAC Project Window, select the Logical View tab and unfold

fields to get an overview of your project:

Project

EREREN

=+ Bubble
=3 Default (Folders)
E-{3 Project Roat

=3 Drive ©
£ Diab
-2 44b
B2 incude
L[ stdioh

[=-{_3 Drive E
E1-{Z2 Program Files
{7 RistanCASE
EH:] Development Assistant for C
B3 Preinclude Files
"] Diab Data PowetPC ¥4,3.h

=14 Defaulk {types)
[#-{_4 ' Source Files
[#-{_3 Assembler Source Files
--{_2 Header Files
--{_2 Document Files
[#-{_3 Miscellaneous Files
=4 Default {states)
[H-{_4 Writeable
[#-{_3 Read Cnly
++{Z2 Changed
[#-{_4 Mot Changed

1 O

Spmbols I Messagesl ‘Yerzion Infol Dependenciesl Comments | Properties [DAC]I

Line | Mame |

32 address_p
46 array

28 array

45 change

70 counk

46 counk

32 get_short
71

49 i

24 inpuk_count
68 main

46 sort

16 swap
26 test_count

2] [l =<0 =] =] <] ] <]

Figure 2.9 Project Window - Logical View (Undocked mode)
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DAE V4.0 Using DAC with Diab Data Tools

]
3 Integrating the Tools
]

3.1 User-Defined Actions (UDA) Setup

To integrate Diab Data PowerPC V4.x tools and GNU make into DAC, on
the Option menu, click User-Defined Actions, and then click the Start
Menu Actions tab.

Now check the Use compiler template check box. By selecting this
option, you have decided on what is probably the most common manner
of using Diab Data tools. The action is contained in the "Diab Data Pow-
erPC V4.x.tpl" file located in the "UDA Templates” subfolder of the DAC
folder. You can edit it and adjust it to your needs. RistanCASE would
appreciate your sharing additional features and ideas with us. Now click
OK.

DAC-40-71-119 ©2002 RistanCASE GmbH -13 -
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User-Defined Actions [ 7] L

Start Menu Actions | Wersion Control Menu Actions I Shartcuts I Command Shell I

— Meru
Chompile File - New I [DElete | Eenamel
Compile &4 Files
ELink All Files

M ake Project i [ I

— Show output data in

e} ¥ Usze compiler
template

& WG DS Frompt. ) U DS Eutputwindow 0 Doani shov autput

— Toolbar

) Mane
= Tient I
| Eicture IDiab_Data_EompiIe_fiIe.bmp Erovse.

—Action scrpt

:Save source file and et dir to project root
- #Update[ZCurFile]

#SetDil*PriRoot]

ESetwin(bIM)

;Ehec:k if the project containg neither C nor ASM source files
Zif(%CFile 2R 2(% True) %R 2(%Falze])

4 |

Ok I Cancel | Sl | Help |

= o L

Figure 3.1 User-Defined Actions - Start Menu Actions

On the View menu, point to Toolbars, and then click User-Defined
Actions. Five UDA buttons should now appear on the DAC toolbar, and
the items Compile File, Compile All Files, Link All Files, Make
Project, and Build Project on the Start menu. On the toolbar, appearing
from left to right, the UDA buttons are:

User Defined Act..E3

cC S o G

Figure 3.2 UDA toolbar (Undocked mode)

+ Compile File oc
+ C ile All Fil

ompile iles o
+ Link All Files L
* Make Project i
+ Build Project

uild Projec ;!

3.2 Makefile Template Setup

In order to completely define the Compile File, Compile All Files, Link
All Files, Make Project, and Build Project UDA with the gmake utility,
a project makefile must be provided. This file should have the same name

-14 - ©2002 RistanCASE GmbH DAC-40-71-119



Using DAC with Diab Data Tools

INFO:

You inevitably have
to make the neces-
sary customizations
of the appropriate
file for their compiler.
Follow the direc-
tions given in the
template file and
consult your com-
piler tools literature if
and when neces-

sary.

as the current project and the extension ".mak". It can be edited manually
or generated automatically.

The template files are generally used to define all the necessary macros,
commands, rules, and so on, which facilitate automatic project makefile
generation by means of the Makefile Template Macro Language instruc-
tions expansion.

Since manual editing is a very tedious and error-prone process, an exam-
ple makefile template "Diab Data PowerPC V4.x.dmt" has been provided
in the "Makefile Generator Templates" subfolder of the DAC folder.

Other files that should be customized to reflect the properties of a target
system on which a program is to be executed is the linker command file
(".dld" extension) and the linker invocation command line file (".cm!"”
extension). If the "Diab Data PowerPC V4.x.dmt" makefile template is
expanded, both files will be generated along with the makefile. The tem-
plate file sections responsible for the generation of those two files are at
the end of the template and is commented.

Linker Command File

The linker command file specifies how the object files in a build will be
linked and located. The template generates the default linker command
file, identical with "default.dld" file located in the "conf"” subfolder of the
Diab Data folder. You should modify this section to fit your project's
memory requirements.

Linker Invocation Command Line File

The linker invocation command line file contains a list of object modules
for linking and a list of linker options.

To enable automatic makefile generation, do the following:

» Copy the file "Diab Data PowerPC V4.x.dmt" from the "Makefile
Generator Templates" subfolder of the DAC folder to the
"example\powerpc" subfolder of the Diab Data folder.

» Customize "Diab Data PowerPC V4.x.dmt" to your needs.

In the line 19, specify the used version of the Diab Data PowerPC
V4.x tools by initialising VERS.

In the line 233 through 288 customize the template section responsible
for the linker command file generation by replacing the default text
with the text listed in the Appendix A.

* Rename "Diab Data PowerPC V4.x.dmt" to "Bubble.dmt".

*  On the Options menu, click Makefile Generator, and then select
Generate makefile or its components.

DAC-40-71-119
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NOTE:

On every start of the
Build or Update the
Database com-
mand from the Start
menu, DAC will
automatically check
if the makefile needs
to be regenerated.

* In the Makefile template box enter "Bubble.dmt" or use the Browse
button to find it.

* Click OK.

* On the Start menu, click Generate Makefile. The makefile for your
project will be generated automatically.

Makefile Generator Options EHE k

¥ Generate makefile or its components

I akefile template

IBubee.dmt Browse... I
Ok I Cancel I Help |

Figure 3.3 Makefile Generator Options

The report of the automatic project makefile generation process is dis-
played in the Messages window under the Makefile Generator tab. After
the project makefile has successfully been created, you can use the Link
All Files, Make Project, or Build Project UDA to generate the
"Bubble.out" file.

The generated "Bubble.mak" file can be opened for inspection. Please,
bear in mind that any changes made in it would be overwritten as soon as
any of the following actions from the Start menu is performed: Build
Database, Update Database or Generate Makefile. This means that if
any changes to makefiles are to be made, the make template file should be
edited instead.

DAC UDA handles compiler error reports and displays them in the Mes-
sages window under the Compiler Messages or Linker Messages tab,
depending on the UDA performed.

3.3 Using Diab Data Tools by Default

If you want your newly created project files to automatically inherit the
proper setup for Diab Data PowerPC V4.x tools, you should also custom-
ize the default DAC project file "dac.dcp”, which is located in the "Pro-
gram" subfolder of the DAC folder.

-16 -
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4 Appendix A

Makefile template section for Linker command file generation:

Linker command file listing:

MEMORY

{

}

0x10000 /* 3rd 64KB */
0x10000 /* 4th 64KB */
0x30000 /* 512KB - 703KB */
0x10000 /* 7043B - 768KB */

0x20000, |en
0x30000, |en
0x80000, len
0xb0000, len

rom: org
rong: org
ram org
stack: org

SECTI ONS

{

GROWP : {

Stext o { *(.text) *(.init) *(.fini) }
.sdata2 : {}

} >ront

Ctext2 @ { *(.text2)

__DATAROM = .;

} > ronR

GROUP : {
__DATA RAM = .
.data LOAD(__DATA ROM : {}

.sdata (DATA) LOAD(ADDR(.sdata) - ADDR(.data) + _ DATA ROV : {}
__DATA END =
__BSS START =
.sbss @ {}
.bss : {}
__BSS END =
__HEAP_START = .
} > ram

}

__HEAP_END = ADDR(ram ) + SIZEOF(ram );

_SPINT = ADDR(stack ) + SIZEOF(stack );

__SP_END = ADDR(stack );

DAC-40-71-119 ©2002 RistanCASE GmbH -17 -
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