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Using DAC with CodeWright IDE

INFO:

In the Reader
Edition, DAC has
full functionality with
one limitation - writ-
ing is disabled in
Editor. In this way, at
a lower price of
DAC, you can use
your usual IDE for
editing, and DAC for
analyzing projects,
Flow charts, Graphs,
Software Metrics,
and so on.

NOTE:

This technical note
only provides infor-
mation on how to
configure DAC to
facilitate your work
with CodeWright
V6.0, for which the
document has pri-
marily been written.
Using it as a basis,
DAC can easily be
configured to work
with later Code-
Wright versions. For
further information
on DAC, please refer
to "Development
Assistant for C" doc-
umentation V4.0.

I Requirements
]

* DAC -V4.0.058 or later - (Development Assistant for C -
RistanCASE). The latest version, with Demo Mode license included,
can be downloaded from the following URL:
http://www.RistanCASE.com/dac/v40/dac_download.php

If you are running DAC in Demo Mode, you can easily obtain a trial
license and enjoy all the comforts of DAC for two weeks! For more
details, choose Technical Support from the Help menu.

* CodeWright V6.0 or later - (Starbase Corporation)

In the following sections, it is assumed that your CodeWright has been
installed in the "C:\Program Files\CodeWright32" folder. In the text that
follows, this folder will be referred to as the "CodeWright folder."

You may have to adapt the paths used in the example provided to match
your current installation paths. The CodeWright folder has to be in the
system PATH.

It 1s also assumed that DAC has been installed in the "C:\Program
Files\RistanCASE\Development Assistant for C" folder. In the text that
follows this folder will be referred to as the "DAC folder."
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2 Installation and Setup
]

To make the most of your CodeWright with DAC, these are the steps to
follow:

e Installing/Uninstalling DAC Support for CodeWright
e Importing a CodeWright project
e Configuring DAC

As you progress through this technical note, you will be led through the
process of installation and deinstallation of the DAC support, configuring
DAC, starting and using the DAC support in CodeWright and in DAC.

2.1 Installing/Uninstalling DAC Support for CodeWright

2.1.1 Installing DAC Support

Before installing DAC support, please quit CodeWright. Then browse
through the "AddIns\CodeWright" subfolder of the DAC folder and start
"DACCWCfg.exe". The following dialog box will appear:
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w DAC-Codewright connection setup M= 3

— Selected Code'wright:

IC:\Program Filez\Code\w/right\cw32 exe

Searching for DAC. . ﬂ

DAL found in folder "C:\Program FileshRistanCASE\Development Assistant for ChProgram”'
ISeIected Code'wright: "C:%Program FileshCode'wright'"!

I~

Copy to clipboard ta e-mail I Irstall 1 kst Cloze |

Figure 2.1 Installing DAC Support

If you have already installed/deinstalled some CodeWright, the last one
you have worked with will be set by default in the appropriate textbox. By
clicking the Browse button, you can choose the CodeWright in which you
want to install DAC support (by choosing the appropriate "cw32.exe”
file). Then, click the Install button. The setup program will add the neces-
sary data in the appropriate CodeWright configuration files, that is:

* Inthe "cwright.ini" file:

In [LibPreLoad] section - it will enter paths to the libraries "DACD-
DEClient.dll" (necessary for communication with the DAC DDE
server) and "DACCWResource.dll" (necessary for displaying the
DAC toolbar in CodeWright).

In [Menu] section - it will add the definition of the DAC menu in
CodeWright, before the Tools menu definition.

In [Ribbon] section - it will add the definition of the DAC toolbar in
CodeWright.

* Inthe "cwright.mnu" file, it will add the definition of the DAC short-
cut menu.

* Inthe "cwright.btn" file, it will add the definition of the DAC toolbar
buttons in CodeWright.

* Inthe "cwright.mac" file, it will add the macros necessary for the con-
nection with DAC. The names of all added macros have the prefix
DAC.

The setup program will copy the original files "cwright.ini", "cwright.mnu"
and "cwright.btn" to the "CW-DAC backup" folder, and will create the
"runDAC.bat" file in the CodeWright folder.
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2.1.2 Uninstalling DAC Support

Before uninstalling DAC support, please quit CodeWright. Then browse
through the "AddIns\CodeWright" subfolder of the DAC folder and start
"DACCWCfg.exe". The following dialog box will appear:

w DAC-Codewright connection setup M= 3

— Selected Code'wright:

IC:\Program Filez\Code\w/right\cw32 exe Browse |

Searching for DAC. . -
DAL found in folder "C:\Program FileshRistanCAS E\Development Assistant for ChPrograms''

Selected Codewfright: ' C:\Frogram Files\Codet/right"'

DAC Support already intalled.

=l

Copy to clipboard to e-mail I rstal Uninztall Cloze |

Figure 2.2 Uninstalling DAC Support

If you have already installed/deinstalled some CodeWright, the last one
you have worked with will be set by default in the appropriate textbox. By
clicking the Browse button, you can choose the CodeWright in which you
want to install DAC support (by choosing the appropriate "cw32.exe"
file). Then, click the Uninstall button. The setup program will copy the
files "cwright.ini”, "cwright. mnu" and "cwright.btn" from the "CW-DAC
backup" folder to the CodeWright folder. It will also delete the file "run-
DAC.bat", and delete all the macros necessary for the connection with
DAC from the file "cwright.mac".

2.2 Importing a CodeWright project

Start DAC and, then, on the Project menu, click Import Project to open
the Project Importer dialog box:

Project Importer HE L
Importer ||§| Code\w/right 6. j Setup ... | About ... |
From praject IE:\Example\Example.pit B

0k | Cancel | Help |

Figure 2.3 Project Importer dialog box

From the Importer list, choose "CodeWright 6.x". Click the Setup button
to display the following dialog box:

©2002 RistanCASE GmbH DAC-40-71-124
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Setup for CodeWright 6.x Project Importer

Code'wright 6. configuration file:

|C:\F'rogram Files\Codetw/right 324 cwright.ini Browse ... |
Ok I

Cancel | Help |

Figure 2.4 Importer setup

In the CodeWright 6.x configuration file box enter: "C:\Program
Files\CodeWright32\cwright.ini", or use the Browse button to browse
through the CodeWright folder and select "cwright.ini". Click OK. In the
From project box enter the name of the CodeWright project you want to
import or use the Browse button to select it. Then click OK.

After that you will be offered to save and open a new DAC project with
the same name and in the same folder as the CodeWright project:

Mew k
Lok jt: |@ E=ample j ﬁl
Bitmaps
Example.C5_

Include
Project Root
Referential Root

File name:

dcp Open I
Files of type: | Project Files [*DCF] =l Cancel |

Figure 2.5 New DAC project with the same name as the CodeWright project

Click Open to open a new DAC project file in DAC.

If DAC and CodeWright’s project files (with the ".dcp"” and ".pjt" exten-
sions, respectively) are in the same folder and have the same name, you
will be able to automatically start DAC from CodeWright.

Using the CodeWright project file and the "cwright.ini"” file, the converter
will convert:

» The list of files used in the project.

» Editor options: font and font size, tab character usage, tab character
length, word wrap option, insert mode, active keyboard layout, EOL
mark, using persistent blocks, syntax highlighting adjustments,
bracket format and other.

* Compiler options and VCS options.

After the conversion has been completed, the DAC Messages window
opens to inform you of the successfully completed conversion and/or pos-
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sible problems, that is, unconverted files. All project parameters can be
additionally changed and adapted through the Options menu to suit your
specific needs. For more information, please see DAC documentation.

2.3 Configuring DAC

2.3.1 User-Defined Actions (UDA) Setup

From the Project menu, choose Open Project, and in the Open dialog
box select and open your DAC project.

Then choose User-Defined Actions from the Options menu, to open the
User-Defined Actions dialog box and click the Start Menu Actions tab:

User-Defined Actions HE L

Start Menu Actions | ‘ersion Control Menu Actions I Shortcuts I Command Shell I

M

New | Delete | Benamel
Up | ™ Use compiler

template

Diown

— Show output data in

" M5 DOS Prompt & UDA Output window — © Don't show output

— Toolbar

" None
I e —
%" Picture |BitmapshCodewright. brop Erowse...l
—&ction script
Savedll ;I

#lLeavesppOnT op[TRUE]
+ow32 "ECunFile” +DACS etPosition] % CunLine, % CurrCaolumn)

ol

Ok I Cancel | Al I Help |

Figure 2.6 User-Defined Actions - Start Menu Actions

Click New to add new UDA and type in the name of the new action
"Switch to CodeWright".

Under Show output data in select the UDA Output window option.

In the Toolbar area click Picture, and then click the Browse button to
browse through the "AddIns\CodeWright" subfolder of the DAC folder
and select the picture file "CodeWright.bmp" for the toolbar button. The
preview of the chosen picture is displayed in the left pane of the Toolbar
area.
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INFO:

For more information
about Action script
and User-Defined
Actions Macros see
the User-Defined
Actions Macros in
Reference Manual of
the DAC Documen-
tation.

NOTE:

The CodeWright
project and DAC
project are autono-
mous. Adding or
removing files from a
CodeWright project
will not result in auto-
matic adding or
removal of corre-
sponding files from a
DAC project. Itis
necessary to add or
remove files from a
DAC project manu-
ally, and vice versa.

In the Action script box, enter the following script:
. YBaveAl |
. Y eaveAppOnTop( TRUE)
+cw32 "%CurrFil e" - XDACSet Posi ti on(%CurrLi ne, ¥Curr Col um)

Click OK.

2.4 Editor Setup
Choose Editor from the Options menu, and then click the General tab:

Editor Options

AutoS ave time 1}

¥ Awta reload on file alert

Figure 2.7 Editor Options

The option Auto reload on file alert at the bottom of the dialog box must
be selected to automatically reflect the changes made in files in Code-
Wright. This does not apply to adding or removing files from the project.

DAC-40-71-124
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3 Using DAC support

You can use DAC support from CodeWright in one of these ways:

Via the DAC menu.
Via the DAC toolbar.

Via the DAC shortcut menu.

Quick Search

Flovs Chart

Faste

Check in
Check out

Definition
Declarations

tatch brace
Flace columi marker

Uszes
Assighments

EnTab
DeTab

Callz Ta
Calls 'within
Uzes Within

Dizplay Mode

Call Hierarchy Grapk
Type Hierarchy Graph

Add file to project
Remave file from project

Metrics

Open include file
File comment
Function comment

Run DAC

nize |DAC Tooks “Window Help
5 I_ Flaws Chart
— Definition
18 Declarations
ain Uzes
Azzignments
eIk To
. Callz “Withir
PHEL ss Within
utpt
Call Higrarchy Graph
Aot Type Hierarchy Graph
Aoty Metrics
Aot
Seh Fiun DAC
Build Database
(11} Update Database
T
RufE

Figure 3.1 DAC menu

Properties. ..

Edit this menu...

Build D atabase
Update D atabaze

Figure 3.2 DAC shortcut menu

W E @ e u G E R R B

Figure 3.3 DAC toolbar
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By choosing the Run DAC command from the DAC menu or clicking the
DAC button on the DAC toolbar in CodeWright, you will start DAC and
open DAC project that corresponds to the actual CodeWright project.

By choosing any of the commands from the DAC toolbar, DAC menu or
DAC shortcut menu in CodeWright, you will switch to DAC where you
will get the results of the chosen command.

For example, you can open the "Example.pjt" project in CodeWright and
start DAC from CodeWright.

Then, start the Build Database command from CodeWright, open the
"mainmod.c" file in CodeWright, and right-click the main() function. If
you choose the Call Hierarchy Graph command from the shortcut menu
(Figure 3.4), you will switch to DAC where you will see the Call Hierar-
chy Graph for the main() function (Figure 3.5).

In another example, if you open the "Hrdwlnit.c" file and choose the com-
mand Flow Chart (Figure 3.6), you will see in DAC the Flow Chart for
the FlowChartDemo function (Figure 3.7).

You may also experiment with other DAC commands in CodeWright and
see their results. For more information about DAC commands, please see
DAC Documentation.

DAC-40-71-124
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{ CodeWright - [C:\Example\Project Root\Contro\MAINMOD.C] - (O] x] L
w File Edit Search Project Test Document Customize DAC Tools Window Help =181 x|
€= - asugs mao = -1 6H ?\
| B EEnaEErhGEE A
Proiecl [=]=] extern void Bl_Axwisdctivate (wvoid): j
extern void events_handle ( _ IHT _ ): =
C:AExamplehE xarmple. pep extern void Bl_Axisictivate(void):
Evample (1 Project] il __INT__ InpBuff [220];
=143 Example (27 Files) __INT__ OutpBuff [11U]:
B4&3 Souce Files _ IHT__ maih rwoids .
-] AI5_B1.C i 4 Flave Chart
W[ BXIS_Y.C Hardware  Find ‘main' in Y petii
- IS _ZC Quick Search =i IUI’.1
ReadInpu Declarations
-~ CAOMMUMIC.C WriteOut Browese for 'main’ u
il g3
[ Hrdwinit.c I AxisAc e— P
- HYDRaULC Y _Awishc ssignments
[ IMTERRUF.C Z_amishc  Maichb
0 B hwish oo o falsTo
- 10.C Place colurmnn marker Call Within
- L C while {1 Usges Within
I EnTab
k
. event o Type Hierarchy Graph
-0} SFTWINIT.C Vrite  Diplayode ’ _
-[ STRUCTURE HIG } Add File to project Metrics
[#23] Header Files return 1 Remaove file from project Fiun DAC
-] Resources } Open include file Build D atabase
(771 Other Files _lLI swxx End: m File comment Update D atabase be see 36 36 3¢
ll—l d Function comment
a |E_- Il[: I@ I = I|j: I || Properties. . _DI_I
|File: C:AE xampleFraject FoathCantrolsMAINMOD.C Edit this menu... Fo [ ne [ [Uine3s [Col 1z

Figure 3.4 Using the Call Hierarchy Graph command on the main() function from the DAC short-
cut menu in CodeWright

xample - Development Azsiztant for C - [Graph from 'main’]

{-Eile Edit “iew Search Browse Graph Metice Documentation  Stat Project Options  Window Help ;Iilll
=R ARER R =N RN e Rl R N2 | vl N -3 G A

PI= = cdEEa ||z rare|w
g I 5|

| £ a | main

Project Root\Control\Hydraul.c ;I

Praject Root\Control\rterfaceh\C mainmad ¢

Project Root\Contralo.c /

Project Root\Control\kainmod.c

Praject Root\Control\Preumat.c
ﬂ Axis Activate I .
L

Project Root\Control\S ftwinit o
Project Root\Control\Structure hi
Praject Root'\Real Time\dwis_b1.
Project Root\Real Time\asis vo
Froject Rooth\Real Time\dyis_z.c <

InpBuft

mainmod.c

e e v e e 1

Praject Root\Real Timeblnterup.
-

cearmhblar Sonrma Filae

4 I 3

=

_—— = Hardwarelnit

CAEXAMPLEYPROJECT ROOTACOMT

Symbols | Messagesl Wersion |4 I 4 M

R $ o

B1_AxisActivate

29 events_handle -

22 Hardwarelnit 2 It

[ ] 32 InpBuff

35 main

E 33 OutpBuif

23 Readinput _ILI

: £ nEAarhedt . .
A Kl _ _>l_I

| [CAPS [NUM

Figure 3.5 Call Hierarchy Graph of the main() function, in DAC
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{" CodeWright - [C:\Example\Project Root\Control\Hrdwlnit.c] [ |O] x| L

w File Edit Search Project Text Document Customize DAC Tool:  Window Help -|ﬁ'|5|
|e-»-asEgswro-  1Hh#e]
[ ST =Y
Pro'ecl HE =~
' case NORMAL =
C:AExamplehE xarmple. pep <% Hormal speed. normal safety. *-
Example [1 Project] ﬂ breénk;
=163y Example [27 Files
IE P [. ! case FAST:
=43 Source Files o% Greatel smeed  les= cofeto %/
-[) 45 B1.C break; | FowChat |
- BRIS_W.C Find 'Greater' in 3 -
default: ; Definition
[ 4HIS_ZC ~% Unknow, Quick Search Declarations
[ COMMUNIC.C 3 return ER o for Greater u
-0 ses
-] HYDRAULE % Tnitialisatiuiers Assignments
-[ INTERRUP.C if { InitCKE } Match brace Calls To
return COK; o
- 10.C cleo Place column marker Calls ‘Within
-] MAINMOD.C /: EEHO: _ EnTab Usez Within
2=CI1 11
[ MCINIT A5M - Acticml:j DeTab Call Hierarchy Graph
-7 PMEUMAT.C *®s f Tvpe Hierarchy Graph
-0 SFTWINIT.C goto Loop: iy e b —
-[ STRUCTURE HIG h Add file to project Blrics
[#23] Header Files Femove file from project Run DAC
D Resources <% DEMO: Getting Tt Open include file Build D atabase
. "1 Other Files . _|' Click the right File: comment Update Database
_I_I =omething from Function comment
Cho=e Graph and = button on "Hard=
a |—_ I-[: I@ ID I|j: I |‘| Properties... »
|File: C:AE xampletFraject RoathCantrolsHrdwinit o Edit this men... lins | [Line: 188 [Cal 13

Figure 3.6 Calling the Flow Chart command from CodeWright

#ample - Development Assistant for C - [Project Root\Control\Hrdwlnit_c]
DEiIe Edit “iew Search Browse Graph Metice Documentation  Stat Project Options  Window Help _|E||1|

|G E Ewm| e 0B |cmi b || w”
22 BlamEea &P & [ENERE N S
InitOK = FALSE; - ;I
<% DEMO: Examnple For MISEL Eu ; >
* De=scription: Labels should not be EEEE
* Action: Double—click on warn
*®.7
Loop : <kl

Marmal speed, normal
S% Answers % safety

switch{ modes )

% less speed, greater safety. =7

pese StoT e )

break Ly
case NORMAL: <K]

<% Hormal spesed. normal =afety case
hreék;hh _I

FAST:

Cas . Greater speed, less
breal:; [4y safety.
default <

## Tnknown, error %~
return ERROR;
3 ; default = [ ]

<% Initialisation OK? =~

if ( InitOK ) =
gm » {_ Unknown, eror ) =

| FlowChartDemo | Insen | t@@1 | [CAPS [NUM

Figure 3.7 Flow Chart of the chosen function in DAC
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4 Troubleshooting
]

Possible problems and ways to overcome them:

Problem Answer

You cannot start DAC The DAC and CodeWright’s projects are
by using the Open not in the same folder.

Project command from Reimport the CodeWright project into
the DAC menu, or by DAC. After reimporting, the imported
clicking the DAC button project should be saved using the default
on the toolbar in Code- path and file name.

Wright.

DAC has been started, If a command does not respond in Code-
but the commands do Wright, there are two possible reasons for
not respond. this:

1. The command started in CodeWright
cannot be carried out in DAC (it is
unavailable)

2. The DDE connection breakup occured.
The established DDE connection can
break if at least one of the programs
(DAC or CodeWright) is quit. You have
to restart CodeWright (DDE client).
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5 Index

C:\Program Files\CodeWright32 1

A C:\Program
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CW-DAC backup 3-4

Action script 7

C
CodeWright 1-3
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X ‘

V6.0 1 Import Project 4 .
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[Menu] section 3 L
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cwright.mac 3-4 Demo Mode 1
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DAC Support P
Install 2

i Project Importer 4
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DACCWResource.dll 3

DACDDEClient.dll 3 R
Requirements 1
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E
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