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Using DAC with CodeWright IDE

INFO:

In the Reader
Edition, DAC has
full functionality with
one limitation - writ-
ing is disabled in
Editor. In this way, at
a lower price of
DAC, you can use
your usual IDE for
editing, and DAC for
analyzing projects,
Flow charts, Graphs,
Software Metrics,
and so on.

NOTE:

This technical note
only provides infor-
mation on how to
configure DAC to
facilitate your work
with CodeWright
V6.0, for which the
document has pri-
marily been written.
Using it as a basis,
DAC can easily be
configured to work
with later Code-
Wright versions. For
further information
on DAC, please refer
to "Development
Assistant for C" doc-
umentation V4.0.

I Requirements
]

« DAC -V4.0.058 or later - (Development Assistant for C -
RistanCASE). The latest version, with Demo Mode license included,
can be downloaded from the following URL:
http://www.RistanCASE.com/dac/v40/dac_download.php

If you are running DAC in Demo Mode, you can easily obtain a trial
license and enjoy all the comforts of DAC for two weeks! For more
details, choose Technical Support from the Help menu.

* CodeWright V6.0 or later - (Starbase Corporation)

In the following sections, it is assumed that your CodeWright has been
installed in the "C:\Program Files\CodeWright32" folder. In the text that
follows, this folder will be referred to as the "CodeWright folder."

You may have to adapt the paths used in the example provided to match
your current installation paths. The CodeWright folder has to be in the
system PATH.

It is also assumed that DAC has been installed in the "C:\Program
Files\RistanCASE\Development Assistant for C" folder. In the text that
follows this folder will be referred to as the "DAC folder."

DAC-40-71-124
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Using DAC with CodeWright IDE

2 Installation and Setup
]

To make the most of your CodeWright with DAC, these are the steps to
follow:

e Installing/Uninstalling DAC Support for CodeWright
* Importing a CodeWright project
¢ Configuring DAC

As you progress through this technical note, you will be led through the
process of installation and deinstallation of the DAC support, configuring
DAC, starting and using the DAC support in CodeWright and in DAC.

2.1 Installing/Uninstalling DAC Support for CodeWright

2.1.1 Installing DAC Support

Before installing DAC support, please quit CodeWright. Then browse
through the "AddIns\CodeWright" subfolder of the DAC folder and start
"DACCWCfg.exe". The following dialog box will appear:
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Using DAC with CodeWright IDE

W DAC-CodeWTright connection setup [_ (]

— Selected CodewwTright:

I C:%Program FileshCode'wrighthcw 3z, exe

Searching for DAL, .. -
DAC found in folder "C:\Program FileshRistanCASE \Development Assigtant for CWProgram®'
ISeIected Codet/right: "' C:\Pragran Filez\Code\wight"

=i

Copy to clipboard to e-mail | Irstall [ irstall Close |

Figure 2.1 Installing DAC Support

If you have already installed/deinstalled some CodeWright, the last one
you have worked with will be set by default in the appropriate textbox. By
clicking the Browse button, you can choose the CodeWright in which you
want to install DAC support (by choosing the appropriate "cw32.exe”
file). Then, click the Install button. The setup program will add the neces-
sary data in the appropriate CodeWright configuration files, that is:

* Inthe "cwright.ini" file:

In [LibPreLoad] section - it will enter paths to the libraries "DACD-
DEClient.dll" (necessary for communication with the DAC DDE
server) and "DACCWResource.dll” (necessary for displaying the
DAC toolbar in CodeWright).

In [Menu] section - it will add the definition of the DAC menu in
CodeWright, before the Tools menu definition.

In [Ribbon] section - it will add the definition of the DAC toolbar in
CodeWright.

* Inthe "cwright.mnu" file, it will add the definition of the DAC short-
cut menu.

* Inthe "cwright.btn" file, it will add the definition of the DAC toolbar
buttons in CodeWright.

* Inthe "cwright.mac" file, it will add the macros necessary for the con-
nection with DAC. The names of all added macros have the prefix
DAC.

The setup program will copy the original files "cwright.ini", "cwright. mnu"
and "cwright.btn" to the "CW-DAC backup" folder, and will create the
"runDAC.bat" file in the CodeWright folder.

DAC-40-71-124
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DAE V4.0 Using DAC with CodeWright IDE

2.1.2 Uninstalling DAC Support

Before uninstalling DAC support, please quit CodeWright. Then browse
through the "AddIns\CodeWright" subfolder of the DAC folder and start
"DACCWCfg.exe". The following dialog box will appear:

W DAC-CodeWTright connection setup [_ (]

— Selected CodewwTright:

IE:\Program Files\Code'wright.cw32 exe Browse |

Searching for DAL, .. ﬂ

DAL found in falder "C:\Program Filesh\RistanCASE\Development Azsiztant for C\Programt'
Selected Codetright: "'C:\Pragram Files\Codelw/ight"
DAL Support already installed.

=

Copy to clipboard to e-mail | [rrstall Uninztall Cloze |

Figure 2.2 Uninstalling DAC Support

If you have already installed/deinstalled some CodeWright, the last one
you have worked with will be set by default in the appropriate textbox. By
clicking the Browse button, you can choose the CodeWright in which you
want to install DAC support (by choosing the appropriate "cw32.exe”
file). Then, click the Uninstall button. The setup program will copy the
files "cwright.ini", "cwright. mnu" and "cwright.btn" from the "CW-DAC
backup" folder to the CodeWright folder. It will also delete the file "run-
DAC.bat", and delete all the macros necessary for the connection with
DAC from the file "cwright.mac".

2.2 Importing a CodeWright project

Start DAC and, then, on the Project menu, click Import Project to open
the Project Importer dialog box:

Project Importer HE L
Importer ||§| Codetwright 6.2 j Setup ... | Abaout ... |
Fram project IC:\ExampIe\Example.pit B

ok I Cancel I Help I

Figure 2.3 Project Importer dialog box

From the Importer list, choose "CodeWright 6.x". Click the Setup button
to display the following dialog box:
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Using DAC with CodeWright IDE

Setup for CodeWright 6.x Project Importer

Codeh/right B.% canfiguration file:

|E:\F'rogram Filez\CodeWwnight 32 cuwright. ini Browse ... |
0k I Cancel | Help |

Figure 2.4 Importer setup

In the CodeWright 6.x configuration file box enter: "C:\Program
Files\CodeWright32\cwright.ini", or use the Browse button to browse
through the CodeWright folder and select "cwright.ini". Click OK. In the
From project box enter the name of the CodeWright project you want to
import or use the Browse button to select it. Then click OK.

After that you will be offered to save and open a new DAC project with
the same name and in the same folder as the CodeWright project:

New 2] L
Look jn: |@ Example j gl
Bitmapz
Example.C5_

Inclhude
Froject Root
Referential Foot

File name:

wample. dcp| DOpen I
Files of type: [ Froject Fies [ DCF) =l Cancel |

Figure 2.5 New DAC project with the same name as the CodeWright project

Click Open to open a new DAC project file in DAC.

If DAC and CodeWright’s project files (with the ".dcp"” and ".pjt" exten-
sions, respectively) are in the same folder and have the same name, you
will be able to automatically start DAC from CodeWright.

Using the CodeWright project file and the "cwright.ini"” file, the converter
will convert:

» The list of files used in the project.

» Editor options: font and font size, tab character usage, tab character
length, word wrap option, insert mode, active keyboard layout, EOL
mark, using persistent blocks, syntax highlighting adjustments,
bracket format and other.

» Compiler options and VCS options.

After the conversion has been completed, the DAC Messages window
opens to inform you of the successfully completed conversion and/or pos-
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Using DAC with CodeWright IDE

sible problems, that is, unconverted files. All project parameters can be
additionally changed and adapted through the Options menu to suit your
specific needs. For more information, please see DAC documentation.

2.3 Configuring DAC
2.3.1 User-Defined Actions (UDA) Setup

From the Project menu, choose Open Project, and in the Open dialog
box select and open your DAC project.

Then choose User-Defined Actions from the Options menu, to open the
User-Defined Actions dialog box and click the Start Menu Actions tab:

User-Defined Actions L

Start Meru Actiong | Wersion Control Menu Actions I Shortcuts I Command Shell I

— Menu

Hew I Delete | ﬁenamel

Up I ™ Use compiler
template

Diown I

— Show output data in

M5 DOS Prompt @ UDA Output window ¢ Don't show output

— Toolbar

" Mane

A —
* Picture IBitmaps\CodeWright.bmp Browse |
— iction sorpt
HESavedl d
#lLeavetppOnTop[TRLUE]

+owd2 U CunFile’ +<DACS etPosition*%CurLine, ZCurColurmn)

r o

Ok I Cancel | Sl | Help |

Figure 2.6 User-Defined Actions - Start Menu Actions

Click New to add new UDA and type in the name of the new action
"Switch to CodeWright".

Under Show output data in select the UDA Output window option.

In the Toolbar area click Picture, and then click the Browse button to
browse through the "AddIns\CodeWright" subfolder of the DAC folder
and select the picture file "CodeWright.bmp" for the toolbar button. The
preview of the chosen picture is displayed in the left pane of the Toolbar
area.

©2002 RistanCASE GmbH DAC-40-71-124
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INFO:

For more information
about Action script
and User-Defined
Actions Macros see
the User-Defined
Actions Macros in
Reference Manual of
the DAC Documen-
tation.

NOTE:

The CodeWright
project and DAC
project are autono-
mous. Adding or
removing files from a
CodeWright project
will not result in auto-
matic adding or
removal of corre-
sponding files from a
DAC project. Itis
necessary to add or
remove files from a
DAC project manu-
ally, and vice versa.

In the Action script box, enter the following script:
. YSaveA |
. Y. eaveAppOnTop( TRUE)
+CcwW32 "% CurrFile" -XDACSet Position(%CurrLine, %Curr Col um)

Click OK.

2.4 Editor Setup

Choose Editor from the Options menu, and then click the General tab:

Editor Options

fuitoS ave time 1]

¥ &uto reload on file alert

Figure 2.7 Editor Options

The option Auto reload on file alert at the bottom of the dialog box must
be selected to automatically reflect the changes made in files in Code-
Wright. This does not apply to adding or removing files from the project.

DAC-40-71-124
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Using DAC with CodeWright IDE

3 Using DAC support

You can use DAC support from CodeWright in one of these ways:

e Via the DAC menu.
*  Via the DAC toolbar.
*  Via the DAC shortcut menu.

Flow Chart
ick Search
| Huick Searc bt
nize |DAC Tool: “Window Help Faste Declarations
¥ I_ Flow Chart | \ Check in Uses
———  Difinition Check out Agsignments
i = Declarations Match brace Calls Ta
e ses Flace column marker Calls “ithin
Agsighments EnTab Uses Within
relr Calls To DeTab Call Hierarchy Graph
. Calls 'within Display Mode » Type Hierarchy Graph
put | "
Uses Withi g
utpL ses win Add file to project Metrics
Call Hierarchy Graph Fiemove file from project Bun DAC
i Type Hi hy Graph
icij ype_ EiATeh Open include file Build D atabaze
Azt 1 Metrics File comment Update Database
i Function comment
Sl Riun DAC
Build D atabaze Properties..
(17] Update Databaze Edit thiz mer. .
T
RuFF
Figure 3.1 DAC menu Figure 3.2 DAC shortcut menu

| 2 @ B o e B By

Figure 3.3 DAC toolbar
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Using DAC with CodeWright IDE

By choosing the Run DAC command from the DAC menu or clicking the
DAC button on the DAC toolbar in CodeWright, you will start DAC and
open DAC project that corresponds to the actual CodeWright project.

By choosing any of the commands from the DAC toolbar, DAC menu or
DAC shortcut menu in CodeWright, you will switch to DAC where you
will get the results of the chosen command.

For example, you can open the "Example.pjt" project in CodeWright and
start DAC from CodeWright.

Then, start the Build Database command from CodeWright, open the
"mainmod.c" file in CodeWright, and right-click the main() function. If
you choose the Call Hierarchy Graph command from the shortcut menu
(Figure 3.4), you will switch to DAC where you will see the Call Hierar-
chy Graph for the main() function (Figure 3.5).

In another example, if you open the "Hrdwlnit.c" file and choose the com-
mand Flow Chart (Figure 3.6), you will see in DAC the Flow Chart for
the FlowChartDemo function (Figure 3.7).

You may also experiment with other DAC commands in CodeWright and
see their results. For more information about DAC commands, please see
DAC Documentation.

DAC-40-71-124
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DAE V4.0 Using DAC with CodeWright IDE

{* CodeWright - [C:\Example\Project Root\Control\MAINMOD_.C] M= E3

Q File Edit Search Project Tegt Document Customize DAC Tools Window Help _|ﬁ||5|
|¢-»-lazagswao [  8# ¢
BEEEECEEL =Y

Project (=[] extern VD:!.CI Bl_AwisActivate (woid): j
extern void events_handle { _ INT _ ):

C:AExamplelE xample. pzp extern wvoid Bl_Amisdctiwvate(woid):

Example (1 Praject] ﬂ _INT_ InpBuff [2207];

=, Example (27 Files) __INT__ OutpBuff [1107]:

423 Source Files _INT_ maib (woids )
- &xIS_B1.C { D 4 Flow Chart
[ AXIS_Y.C Hardwars  Fid nain'in Y et
) efinition
D ax|5_Z0 Reqdlnpu Quick Search Declarations
D COMMUNIC.C WriteOut Braweze for ‘main’
- Hrdwlric.c ¥ heiso Uses
[ HYDRAULLC ¥ Amisho. 00T Assignments
- INTERRUP.C §1A§i$A§ Match brace Calls Ta
-y I0.C —AELS Place column marker Calls "fithin
- while (1 EnTab Usges Within
[ MCANIT ASM i DeTab S —
InpBu Call Hi W Graph
- PMEUMAT.C R
g SFTWINIT C Tiite DislayMode » _ Tope Herarchy Gragh
- STRUCTURE HIG ¥ Add file bo project Metric:s
1] Headsr Files return 1 Fiemove file from project Run DAL
i | Fiesour.ces ¥ Open include file Build Database
, (771 Other Files . | sxex End: m  File comment IIpdate Database be 3 3¢ 36 3¢ 3¢
—I—I Funiztion commment
o |L—_ Il[: I@ Ig I B3 I |« Properties... Ll—l

|File: C:AE #ample*Project RoatContalMAINMOD.C Edit this menu... F2 e [ |lnes3s [cobiz
e

Figure 3.4 Using the Call Hierarchy Graph command on the main() function from the DAC short-
cut menu in CodeWright

Example - Development Assistant for C - [Graph from "main’]
{-Eile Edit Miew Search Browse Graph Metrice Documentation  Stat Project Options  Window  Help _Iﬂlil

[ Es tan- Q7 |(|lcaier | |ipd| R &>
iz cilEEs [srapn|eE[=]="
e

5 I[:I a | main
j Praject Rooth Cantral\Hydraul.c ;I
Project RootControls nterface\C / mainmod.c

[ |

Events

Project Rooth Control\o.c

Praject Rooth ContralsMainmod. ¢
Project Rooth Control\Prieumat.c

O
O
E|
O
[ Project Root\ControlSitwirit.c
E|
O
O
E|
O

InpBuft Axis Activate

Praject Rooth Cantral\Structure hi
Project RoothReal Timehaxis_bl.
Project RoothReal Timehasis_n.o
Praject Root\Real TimebAxis_z.c <

mainmaod.c

Project RoothReal Time\nterp.
-

Aecarablar Conrma Filas

N . L
C:HMEXAMPLESPROJECT ROOTACOMT

Symbols | Messagesl Wersion |4 I 4 M

A $ o

Hardwarelnit

Line I M ame -
28 B1_Awizdctivate
29 eventz_handle
22 Hardwarelnit
32 InpBuff —
35 main
33 OutpBuff

D E Rt
K o ;I_I

| [CAPE [NUM

R5422_Init

oEEEERR

-

Figure 3.5 Call Hierarchy Graph of the main() function, in DAC
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{* CodeWright - [C:\Example\Project Root\Control\Hrdwlnit.c] M= E3
‘| File Edit Search PFroject Test Document Customize DAC Tools Window Help =
File Edit Search P T i] C DAC Tool: ‘Wind Hel 18] x|
|¢-»-lazagswao [  8# ¢
BEEEECEEL =Y
 Project X =
—— case NORMAL: =
C:AExamplelE xample. pzp <% Hormal speed. normal safety. *7
Exampla [1 Project] ﬂ hreék;
=k Example [27 Files
E P [. ! case FAST:
E1423 Source Files % Greatde sre=d oo =ofeto %
0 s 1 s N
- AxIS_Y.C Find ‘Greater' i »
0 = default: |n. L Srea erhm Definition
"0 Axis 2k 7% Unknowr fluick Seare Declarations
- COMMUNIC.C ) return ER poce for Greater u
-0 ses
~[ HYDRALLE sx Tnitialisatil o0 Assignments
[ INTERRUP.C if EnitOgK? Match brace Call: To
-y I0.C els;e urn ’ Place column marker Callz Within
- MAINMOD.C <% DEMO: EnTah Uses Wwithin
* [ ipt i
g EE;EH:_}SE * Agﬁfgip * DeTab Call Hierarchy Graph
. *® f Type Hierarchy Graph
- SFTWINIT.C gota Loop: il e D :
- STRUCTURE HIG } Add file to project Metric:s
{27 Header Files _ Remove file from project Fiur DAC
{17 Resources /% DEMO: Getting L. Open include file Build Database
. (770 Oither Files - | Click the right File comment Update Database
_I_I something from Function comment
Chose Graph and = = button on "Hardw
e |E_— I't: I@ I = I E3 I | 4 | Froperties... »
|File: C:\E #ample*FProject FootCantrolsHrdwinit.c Edit this menu... lins | [Line: 188 [Col: 19

Figure 3.6 Calling the Flow Chart command from CodeWright

Example - Development Assistant for C - [Project Root\Control\Hrdwlnit.c]
DEiIe Edit Miew Search Browse Graph Metrice Documentation  Stat Project Options  Window  Help _Iﬂlil

a2 E Em| tBlo| B || &8s |w”
IEP=0= P == =R S o B e o

InitQE = FALSE:

% DEHO: Ezample For HISEAZ Fu ; >
#* Description: Label=s should not be CEISE

* Action: Double-click on warn
*.
Loop: <K]

| B
=
=
|

Marmal speed, normal
A% Answers ® safety.
=witch{ mode )

<% lez=z speed, greater safety. *-

S Ceak )

break My
case HORMAL:<K]

~%* Hormal speed. normal safety case
break by [

case FAST: <K
% = ] - Greater speed, less

breal [N\ safety.

default: k]

~% Tnknown, error =~
t EERROR:
! return default [ |

~# Initialisation CK? =~

if { InitOK ) -
ge N [ Unknown, error ] =

| FlowChariDema | Inse | @@l | [CAPS [NUM

Figure 3.7 Flow Chart of the chosen function in DAC
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4 Troubleshooting

Possible problems and ways to overcome them:

Problem

Answer

You cannot start DAC The DAC and CodeWright’s projects are
by using the Open not in the same folder.

Project command from Reimport the Code Wright project into
the DAC menu, or by DAC. After reimporting, the imported
clicking the DAC button project should be saved using the default
on the toolbar in Code- path and file name.

Wright.

DAC has been started, If a command does not respond in Code-
but the commands do Wright, there are two possible reasons for

not respond.

this:

1. The command started in CodeWright
cannot be carried out in DAC (it is
unavailable)

2. The DDE connection breakup occured.
The established DDE connection can
break if at least one of the programs
(DAC or CodeWright) is quit. You have
to restart CodeWright (DDE client).

-12 -
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